cancel
Showing results for 
Search instead for 
Did you mean: 

Installer gave me two errors

2EyeGuy
Adventurer
I got two errors running the installer.
First, it said something like a reboot is pending, reboot your computer before running the installer. But the installer continued installing after that.
Next, I think it said "This app requires the 1.2.x version of the Oculus Display Driver.", although it's possible I was still running Tuscany and that error dialog was already on the screen. But I think it came from the installer.
Then it continued installing and said it had installed correctly.
Then it said to complete installation it had to reboot the computer. Out of curiosity, I tried running Tuscany anyway, and it still gave me the error, so now I'm going to restart like it told me too.
15 REPLIES 15

PatimPatam
Protege
I haven't been able to install the 0.4.4 runtime. First time that i have a problem with Oculus updates (have changed many times between 0.4.3 and 0.4.2 without issues).

I uninstalled 0.4.2 first (and rebooted), then when i ran the 0.4.4 setup i got the dialog from the Oculus Display Driver:
"Please wait while Windows configures..."
but immediately i got another dialog on top of the first one saying:
"There is a system reboot pending. Please reboot your system and run the installer again".

After rebooting i noticed the Rift light was blue, i went to Rift Display Mode and everything except DK1 Legacy App Support was greyed out. On top it said:
"There is a problem with your installation: Oculus Display Driver is NOT installed!".

If i try to run the 0.4.4 installer again it happens the same (tried 3 times). I don't have any Windows updates pending. I'm on Windows 7 - 64bit.

I checked "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager" and i do have a PendingFileRenameOperations file, here's the info:


\??\C:\Windows\TEMP\logishrd\LVPrcInj01.dll

\??\C:\Windows\TEMP\logishrd\

\??\C:\Windows\TEMP\logishrd\LVPrcInj02.dll

\??\C:\Windows\TEMP\logishrd\

Anonymous
Not applicable
Can you rename PendingFileRenameOperations to PendingFileRenameOperations2 in your registry and try the installer again?

PatimPatam
Protege
Yep that worked fine! I tested the Demo Scene and everything seems ok.

Only odd thing i noticed is that the "About" Dialog of the Oculus Config Utility says:
Display Driver Version: 1.2.0.0

But if you check on the Windows Install/Uninstall Programs panel it says:
Oculus Display Driver - Version: 1.2.0.1

Anonymous
Not applicable
Thanks, so it looks like that PendingFileRename key was orphaned from a logitech install:

\??\C:\Windows\TEMP\logishrd\LVPrcInj01.dll

\??\C:\Windows\TEMP\logishrd\

\??\C:\Windows\TEMP\logishrd\LVPrcInj02.dll

\??\C:\Windows\TEMP\logishrd\

So, we'll have to rework the watch for System Pending Reboot on our end.

The 1.2.0.1 in Programs and Features is a tick I have set for this group, the version you're seeing in Config Util is correct.

Thanks again!

2EyeGuy
Adventurer
"PatimPatam" wrote:
If i try to run the 0.4.4 installer again it happens the same (tried 3 times).

I had to try 4 times before it worked, so I don't think trying 3 times is enough. I didn't have any Windows updates pending.
BTW, I installed directly over 0.4.3 without uninstalling anything.

owenwp
Expert Protege
It worked for me on the second try, from 0.4.3.