Showing results for 
Search instead for 
Did you mean: 

Oculus app not working / black window / rendering?


Hi guys,

I was trying to install the PC App today. The installation worked quite fine. The moment when the VR says to establish the link in the VR and the rest have to be done on the Computer, my Oculus App starts.

This is how it looks like:

I've updated the NVidia graphics driver and repaired the Oculus app. What else can I do? My firewall is off and there is no Virus Defender installed, the active Virus control from Windows is off.


EDIT: Reddit Thread with official oculus support statement:

EDIT2: Use Oculus Tray Tool to restart or kill the service, works fine for me, while troubleshooting back and forth.
Download Link here:

EDIT 3: I have added another mirror for Support.rar, Oculus Tray Tool and USB Deview:

158 REPLIES 158


crrrl do u want to creat the discord



For those interested in a discord to keep in touch about this issue.

Honored Guest

One more impacted by this issue


Still no fix? I don't think its possible to fix until oculus fixes it on their end.


We have a solution guys. Strikekat from discord posted a zipped file to downgrade the client version and it works!

  1. You will need to download this file: have downloaded it myself, its around 580MB.
  2. Then, use something like Oculus Tray Icon ( to kill the oculus service.
  3. Then replace the files in your C:\Program Files\Oculus\Support folder with those from the zipped file and voila!
  4. After that, restart oculus app and it should work.
  5. After the full setup process, you might need to uninstall and install it again to have the latest version! But then it should work properly!

EDIT: I have added another mirror for Support.rar, Oculus Tray Tool and USB Deview:


Discord Group:

Youtube Vid:

Thanks again to StrikeKat!

Honored Guest

In the logs of the Oculus service, I see this error message: FBNS Manager Token verification timed out, attempting to register again.

And then it loops

This solution works! We figured it out on discord! Thanks everyone for their effort!

Is there a discord link I can go to to get help setting this up?

It's in the post I shared earlier 🙂

Honored Guest

But this does not work with SteamVR it tells me to update my oculus software.

Or is there a workaround too?