Showing results for 
Search instead for 
Did you mean: 

Oculus app not working / black window / rendering?

Level 4

Hi guys,

I was trying to install the PC App today. The installation worked quite fine. The moment when the VR says to establish the link in the VR and the rest have to be done on the Computer, my Oculus App starts.

This is how it looks like:

I've updated the NVidia graphics driver and repaired the Oculus app. What else can I do? My firewall is off and there is no Virus Defender installed, the active Virus control from Windows is off.


EDIT: Reddit Thread with official oculus support statement:

EDIT2: Use Oculus Tray Tool to restart or kill the service, works fine for me, while troubleshooting back and forth.
Download Link here:

EDIT 3: I have added another mirror for Support.rar, Oculus Tray Tool and USB Deview:

158 REPLIES 158

it seems this problem is recent

Level 3

Same problem, i did the windows update. Try to uninstall and re install the app. It doesn't work.

I dont think about the problem come from my PC.

Config; Intel Core I9

             RTX Geforce 3090

             64 Gb Ram

I found this topic on the forum already... but I did as requested and it didn't help.


Additionally, I opened a new topic on oculusquest on reddit last night, but somehow I got downvoted 😕

Level 3

Dang. Yeah its specifically after choosing a profile picture on new setup. Can't find any topics on Google talking about it. I had to come to support forums to find all these people having the same issue.

Level 3

I might just return my oculus quest 2

Level 3

Same problem, after selecting profile picture the gray screen appears and nothing happens after that..

Level 3

1. Disconnect your computer from the internet

1. Backup any necessary content.

2.You can find steps on how to do so by clicking here.

1.Reboot into Safe Mode.

2.Uninstall Oculus Home using the Control Panel.

3.Delete all Oculus folders from the following order:

3. C:\Program Files

1.Remove any Oculus folders from the following locations:

4. C:\Users\YourUserProfile\AppData
5. C:\Users\YourUserProfile\AppData\Local
6. C:\Users\YourUserProfile\AppData\LocalLow
7. C:\Users\YourUserProfile\AppData\Roaming
8. C:\OculusSetup-DownloadCache

1. Restart your computer in normal mode.

2. Reconnect your computer to the internet.

3. Install Oculus Home again using the setup tool from our website here.


Try this steps. A user back from 2019 had this issue and worked this way. Don't know if it will solve. As it seems, this is a common issue that no one have a right answer.

I have posted it already above and tried it also, didnt work for me. Several users in the same thread were saying that not everybody could solve the problem this way. It might have worked only for a few.

Level 2

Got the same problem, i hope Oculus fixes this really fast.

Level 3

Same issue here. Just bought Oculus Quest 2 today to play PC games. Bad luck.