Showing results for 
Search instead for 
Did you mean: 

So... not sure if you know about this, Oculus, but...


Hey Oculus! So, I have experienced problems with my Rift S lately. So what was happening was that I was playing some Lone Echo, then all of a sudden, it completely freezes, makes a flatline kind of sound, and completely **bleep**ing crashes. I hear some static-y kind of noise after it goes completely black, the game completely crashes and reads it as a hardware error, and telling me to see if my headset is connected. Guess what? Firmly seated into the port. I see absolutely NOTHING. I tried reseating the cables, didn't work. I tried reinstalling the software, didn't work. I tried restarting the PC, nothing worked. I tried plugging the DisplayPort and USB 3.0 back in again after it, does it again after three **bleep**ing minutes. THREE! Oculus, please help me what I am currently suffering. This has gone on for FIVE months. After it crashes, It COMPLETELY looses connection, like it wasn't even connected. If anyone is experiencing the same problem and solved it, please tell me, and how you fixed it. If you are experiencing the same problem, please comment how you can relate.







In other words of this, my Rift S freezes, and I hear a flatline-ish noise as soon as it freezes, and then it crashes, and makes a static noise for four seconds. DisplayPort and USB connection completely lost. Screen still black, with a yellow light. Blue light was off. Like I never used it today.


This is for anyone who didn't understand the paragraph above.


       Again, Oculus. Please help me with what I'm in and I hope you understand.





I couldn't not put this. I'm so excited for Lone Echo II!