Showing results for 
Search instead for 
Did you mean: 

New test users ignore new passwords, don't get entitlement privileges?

Honored Guest

I was adding some test users to my organization to debug in app purchasing and for networked multiplayer testing in our Unity Project, but platform keeps telling me they don't have entitlement for the app (Couldn't verify your Oculus credentials. Will Quit:Missing entitlement for *************) I am developer in the organization, and made the test users with that account, and when I log on with those credentials I get entitlement fine.  This is the behavior when I'm logged in as the test user on the oculus app.  If I check the 'Use Standalone Platform' box, in the Oculus Platform settings and put in the credentials there, the 'GetLoggedInUser' callback never fires.

Also, if I make a new test users, their new passwords are rejected, and I have to use the password for the very first test user I created (thank god I didn't forget its password).

I actually revoked the credentials for my 1st test user, so I'm wondering if subsequent test users are incorrectly inheriting revoked credentials?  I see no way to delete test users, or re-grant privilege so I'm worried I've shot myself in the foot.

I'm using the Oculus SDK 1.38.0, Unity 2018.4.21.  I also tried opting in to the public test channel but Unity would crash on play mode if I tried get entitlement with test users, among other horrors (that's probably another thread).

Any insight would be greatly appreciated!


Honored Guest
After the the most recent update, the entitlement check for my test user crashes Unity. (I saw this behavior before when I had opted into the public test channel, but now it's happening outside that too).  I would really love it if these test users worked, but all they've given me is heartache.