cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest is running Android 7.1(API level 25) while all documention and tools state using 8+

m2-funomena
Level 2
I'm currently able to build and run my game just fine using API 25, but all the documentation and and the lint tool suggest going to API 26+.  When I install I get the INSTALL_FAILED_OLDER_SDK ...  Requires newer sdk version #27 (current version is #25) error.  It appears my device is up to date (333700.3780.0) but when I check the API version on the device(using adb shell getprop ro.build.version.sdk) it states 25.  Doing this to all our devices gives the same result. 

I was wondering, are we missing something?

Thanks

using:
Unity 2019.2.0f1
jdk 1.8.0_77-b03
ndk r16b


3 REPLIES 3

cold_front17
Level 2
Same here, even my quest is up to the latest version of software, the getprop still gives me a API level 25. Also I had several app failed to run after deployed to the quest, because in unity player settings I gave them API levels higher than 25. I think maybe oculus is updating the OS / runtime, but not updating the ground level android it is running on? 

Skalbe
Level 2

Necro bump. Same here still. Working from Unreal. The docs say that Quest is running 8.0-Oreo, which is 26, but Unreal build tool keeps refusing to build with 26, saying that device has older.

CarpetFace
Level 5

I just ran that command on mine and it reports 29 for me.  Perhaps this has changed since the original post?