Showing results for 
Search instead for 
Did you mean: 

120hz Support Broken/Missing on Quest 3??

Honored Guest

We're in the process of updating our game for Quest 3, and we want to support 120hz as an option, but it doesn't seem to be a supported frequency.

As an example, when we call "OVRPlugin.systemDisplayFrequenciesAvailable", we get:

"72, 72, 80 80, 90, 90"

Here's what we've done to try to get 120 to work:

  • The option is turned on in the headset's settings
  • The headset is up to date (Version: 49743630046900510, FW:
  • Restarted the headset, checked for additional updates etc. 
  • Using latest com.meta.xr.sdk.all@59.0.0
  • Using latest Oculus XR Plugin (3.3.0)
  • Using latest XR Plugin Management (4.3.3)
  • Using Unity 2021.3.26 

The only thing that seems like it should have an effect, is the first thing, making sure it's turned on in the quest settings.

Weirdly, 120HZ was working on a Quest 2 a few weeks ago (haven't gotten around to retesting locally yet).

Edit: Just tested it today, and the same build can be set to 120hz on the Quest 2, but not the Quest 3.

For what it's worth, it sounds like perhaps DeoVR users have encountered the same issue, as seen here.

Is it expected that the Quest 3 doesn't actually have native 120hz support yet?



I haven't tried OVRPlugin.systemDisplayFrequenciesAvailable sorry

Maybe you can just run Unity.XR.Oculus.Performance.TrySetDisplayRefreshRate(120)

What does it return? Should be true, works on mine

Will give that a go! 🙂
(sorry for the late reply - this site wouldn't let me reply without turning on third-party cookies)

No luck unfortunately. It might be worth noting that Unity.XR.Oculus.Utils.GetSystemHeadsetType() returns Meta_Quest_Pro (aka Placeholder_10).
I am not certain, but I wonder if this related to the fact Quest 3 isn't added to the manifest.
There isn't the option to add it in the OculusXR plugin management screen, and I haven't spent the time to figure out how to add it manually (as well as exactly WHAT to add).

no i didnt add any Quest 3 to any manifest. I think it just worked

Quest 3 isnt an option (XR Plugin Management -> Oculus ->  Target Devices)

2 options: Quest 2, Quest Pro

I have Quest Pro unchecked

What is returned by TrySetDisplayRefreshRate?



I use Oculus XR Plugin 4.0.0 May 05 2023

are you still on 3.3.0

Try my 120FPS Unity on Quest 3: Repossessed

I found the issue! I needed to tick the Quest 3 box in the OculusProjectConfig scriptable object.

I hadn't thought to look there, as honestly, we wouldn't have touched that since mid 2021.

My understanding is that doing this adds it to the manifest. Not sure how that interacts with the tick boxes in the XR plugin management area.


I have no idea what OculusProjectConfig is but great news well done!