Showing results for 
Search instead for 
Did you mean: 

APK Not Signed On Upload To Release Channel

Honored Guest
I am getting an APK not signed message on build upload to a consumer release channel on Oculus Dashboard, however it was working, details below.

This is the output from apksigner

Verified using v1 scheme (JAR signing): false
Verified using v2 scheme (APK Signature Scheme v2): true
Number of signers: 1

I have no problem with Unity 2019.4.19 using the Standard Utilities Plugin and the previous Oculus Integration (not sure what it was but not 23.1)

However, I am now using 2020.2.4, with XR Plugin Management 3.2.17, Oculus XR Plugin 1.7.0 and Oculus Integration 23.1

The application builds and works on the Quest, but whether I build via Unity, export to Android Studio and build there or even export and force Android Studio to sign the application using Generate Signed Bundle/APK, I get the same error.

I have tried a new Keystore, checked gradle files and a variety of other items.

The build settings are pretty much the same as in 2020 to 2019, so I am at a loss. 

Any ideas?

Honored Guest
I am going to file this as a bug. I went back to Unity 2019 and removed OpenXR and back on track for the time being.


Same issue for me. Works great on device with the keystore setup. Whenever I try to hop back to 2019 though I hit a lot of issues with the TextMeshPro plugin for some reason though, so no luck yet.