Showing results for 
Search instead for 
Did you mean: 

Developer Mode Quest Pro

Honored Guest

Hey 🙂

I bought a Meta Quest Pro because I would like to develop some small projects for these glasses. I'm also very excited about the device, but I've already encountered a more or (I hope) less big problem pretty quickly and hope you can help me here.

The issue is that I can't get the glasses properly into Developer Mode and thus connected to my PC or the app.
I have tried many different ways, downloaded software updates, used different cables, worked with the app and dev hub, run power cycles and rebooted all devices, but I have not been able to solve the problem.
I always get to the step where I have to allow debugging via USB on the headset. I remember this from the Quest, where it worked fine, but on the Pro this prompt just doesn't appear for me to give my permission.

After some searching, I came across a thread here that also describes exactly this problem and where in the further course, quite current is written that there is a solution for it...can you help me find this solution?

I have already looked around a bit in the forums as I said and ended up here:

I had then written to the support chat, as well as the mod from the forum entry, both of which unfortunately could not help me directly, but forwarded me to the PM of the meta support and they forwarded me to the consumer support and this page... i would really appreciate if someone can help me...Unbenannt.PNG

It also works really everything great, except the last step "allow access". When I connect the headset via cable to the pc, there is a nice sound, but no window to confirm.

Thank you very much and with kind regards


Honored Guest

Having exactly same issue... on q2 everything went well connected and I was able to sideload app but QP I cannot give the permission and only MTP connection works - which is meaningless..

Honored Guest

Try using a different USB C cable...the one supplied with the meta quest does not work. You need a "thick" one ...i.e. a monitor cable. It worked for me with this
It's probably too expensive to include a suitable cable 😉