Showing results for 
Search instead for 
Did you mean: 

Error in mobile app when try to set developer mode

Honored Guest

I cannot set developer mode after doing a factory reset on my Quest 2. I'm having the black screen issues, so I did a factory reset to try to solve it. But it doesn't help and now I'm trying to get developer mode to disable proximity sensor, but when I switch the developer mode button in mobile app I'm getting the error shown in the picture. The message in red says: we're having trouble completing your request. Try again... I haven't had problems to set developer mode before. But now it seems impossible. I tried all common troubleshooting... Remove phone number / CC in developer account, I created a new developer account, changed the Oculus account, tried in another phone, etc. Nothing helped. Because black screen I cannot even enter the Oculus home. Tried all known troubleshooting to solve Oculus black screen issue, nothing helped too.






Yes, same here. I tried using the desktop ODH app, also failed...

Honored Guest

Exactly the same issue. So far I've tried to enable it through ODH, both wired and wireless, but to no avail. Haven't tried the factory reset yet, have a project sitting in there from which I lost the apk, recompiling it would take ages.

Honored Guest

Althou I didn't want to resort to this initially, factory reset solved the issue.

Steps to do factory reset:

1) Turn off the headset.

2) Push and hold volume down + power buttons until you see the Meta logo.

3) Select and confirm factory reset using volume buttons do go up and down, and power button to select.

4) Wait for reset to end.

5) Perform the initial setup.


I'm SOOO TIRED OF OCULUS. I have had to unisntall the app SOOO many times because of errors like this a ton of times. I have to factory reset three times and have to redo the developer process twice. Now I think the problem is that my quest says I have developer options but the phone app says I don't but I can't reenable it. I'm TIRED and they NEVER answer support tickets for problems like this! I can't work like this!! Oculus, fix your **bleep** app!!!!