Showing results for 
Search instead for 
Did you mean: 

Failed to sideload after 1st successful sideload

Honored Guest

  I'm new to Quest development and have created the test app from  Part way through I did a build and run which worked perfectly.  Then I went back to Unity to finish the tutorial.  After I finished the tutorial, I did another build and run which completed successfully (no displayed errors).  But, when I clicked in to the app on my quest, it was still the first build.  So, I did an uninstall from within the Quest and tried the build/run again. This time the app didn't appear in the Quest's "Unknown Sources" list like it had before.  Then I remembered seeing the "adb logcat" command so, I tried running that in a CMD window while doing a build and run.

  I have no idea what these errors mean and couldn't find anything online about them.  Any help would be greatly appreciated.





02-06 10:44:14.753   802   818 D installd: Found valid user 10
02-06 10:44:14.753   802   818 E cutils  : Failed to open(/data/misc/profiles/cur/0/com.DefaultCompany.VRProject/ No such file or directory
02-06 10:44:14.753   802   818 E installd: Failed to prepare /data/misc/profiles/cur/0/com.DefaultCompany.VRProject/ No such file or directory
02-06 10:44:14.754  1053  1093 E ArtManagerService: Failed to prepare profile for com.DefaultCompany.VRProject:/data/app/com.DefaultCompany.VRProject-bWug2tl_Z-LFQLGy29ypXA==/base.apk
02-06 10:44:14.754   802   818 E cutils  : Failed to open(/data/misc/profiles/cur/10/com.DefaultCompany.VRProject/ No such file or directory
02-06 10:44:14.754   802   818 E installd: Failed to prepare /data/misc/profiles/cur/10/com.DefaultCompany.VRProject/ No such file or directory
02-06 10:44:14.757  1053  1093 I PackageManager.DexOptimizer: Running dexopt (dexoptNeeded=1) on: /data/app/com.DefaultCompany.VRProject-bWug2tl_Z-LFQLGy29ypXA==/base.apk pkg=com.DefaultCompany.VRProject isa=arm64 dexoptFlags=boot_complete,profile_guided,public,enable_hidden_api_checks targetFilter=speed-profile oatDir=/data/app/com.DefaultCompany.VRProject-bWug2tl_Z-LFQLGy29ypXA==/oat classLoaderContext=PCL[]
02-06 10:44:14.758   802   818 V installd: DexInv: --- BEGIN '/data/app/com.DefaultCompany.VRProject-bWug2tl_Z-LFQLGy29ypXA==/base.apk' ---
02-06 10:44:14.798  5575  5575 I dex2oat : /apex/ --input-vdex-fd=-1 --output-vdex-fd=11 --resolve-startup-const-strings=true --max-image-block-size=524288 --compiler-filter=speed-profile --classpath-dir=/data/app/com.DefaultCompany.VRProject-bWug2tl_Z-LFQLGy29ypXA== --class-loader-context=PCL[] --generate-mini-debug-info --compact-dex-level=none --compilation-reason=install
02-06 10:44:14.800  5575  5575 I dex2oat : setting boot class path to /apex/
02-06 10:44:14.848  1053  1065 I system_server: Background concurrent copying GC freed 121828(5662KB) AllocSpace objects, 51(1680KB) LOS objects, 42% free, 11MB/19MB, paused 102us total 128.822ms
02-06 10:44:14.849  1053  1066 W JHwRemoteBinder: BinderProxy is being destroyed but the application did not call unlinkToDeath to unlink all of its death recipients beforehand.  Releasing leaked death recipient:$WifiDeathRecipient
02-06 10:44:14.850  5575  5575 I dex2oat : Explicit concurrent copying GC freed 769(354KB) AllocSpace objects, 0(0B) LOS objects, 99% free, 424B/1536KB, paused 14us total 1.643ms
02-06 10:44:14.857  2044  5586 I OSUpdateService: Intent with action system_battery_changed
02-06 10:44:14.881  5575  5575 I dex2oat : dex2oat took 85.510ms (113.959ms cpu) (threads: 😎 arena alloc=13KB (13576B) java alloc=16KB (16808B) native alloc=901KB (922688B) free=382KB (392128B)
02-06 10:44:14.883   802   818 V installd: DexInv: --- END '/data/app/com.DefaultCompany.VRProject-bWug2tl_Z-LFQLGy29ypXA==/base.apk' (success) ---