Showing results for 
Search instead for 
Did you mean: 

Mobile SDK Setup

Level 3
Hi everyone,

I'm trying to follow the mobile SDK guide but I'm having trouble building the samples. I'm not super familiar with Gradle and other Android shenanigans so I'm completely lost. 

I'm basically trying to follow the "Android Studio Basics" part but I'm never asked if I want to use the Gradle wrapper. ( Step 3 ). I tried to keep going but I'm almost immediately hit with a "Task 'wrapper' not found in project", which isn't surprising.

I've tried to Google this and figure out what's going on but no luck so far. What am I missing?

Thanks in advance for your help!

EDIT: Using build.bat from VrCubeWorld_Framework\Projects\Android it works. My Android Studio / Gradle integration is still messed up though.

EDIT 2: You probably shouldn't do that because it doesn't make much sense, but I copied and pasted the "gradle" folder from the root of the VR Samples folder inside  VrCubeWorld_Framework\Projects\Android and now it works. ¯\_(ツ)_/¯

Level 4
Dude! Same here; This is the third attempt at getting something going on the Oculus; the Unreal route: opaque errors, Unity: crash/hang on project test run/export, Native: now this issue. 
I really am surprised there's no info to be found, as if this is some rare occurrence or the issues so simple as to need no explanation. 
Only recently been taking a crack at some app development,& I am amazed at the multiplicity of frameworks, redundancy of tools that purport to make things easier, but instead bloat & cause seemingly impenetrable issues. 

Level 3
I've managed to compile examples and have described some workarounds. In case anyone needs it, it's on my Steem blog, alias tete-steem . I can't post links yet.