cancel
Showing results for 
Search instead for 
Did you mean: 

Movement SDK features fail to start on Quest Pro

Markcreator
Level 2

I've been trying to access the new Eye and Face Tracking features of the Quest Pro using the latest Integration SDK (46.0), though I am having some trouble.

OVRPlugin.StartFaceTracking() fails (Failure, error code -1000), and OVRPlugin.faceTrackingSupported returns False. I have tested both in Airlink (Android build target) and built APKs, but no luck.

I have followed the project setup on the Movement SDK page and believe I am on all the latest and correct SDKs and runtimes. Face tracking is also enabled in the headset and works fine in Workrooms.

Might anyone else have this issue, have an idea about what could possibly be wrong, or have a suggestion on what I might be able to try?

5 REPLIES 5

Markcreator
Level 2

So I was able to get the Movement SDK features working on built APKs by adding the following metadata to the AndroidManifest.xml:

<uses-feature android:name="oculus.software.face_tracking" android:required="true" />
<uses-feature android:name="oculus.software.eye_tracking" android:required="true" />
<uses-permission android:name="com.oculus.permission.EYE_TRACKING" />
<uses-permission android:name="com.oculus.permission.FACE_TRACKING" />

 These aren't documented very well in the documentation at this time, though I was able to figure them out by reading ALVR source code.

 

I still cannot test these features in-editor unfortunately.

You wouldn't be willing to share a basic setup on GitHub would you? I don't know why Oculus wouldn't have an example scene to show this working. And that completely sucks if you can only use those features on native APK builds and not in the Editor and Windows builds. Hoping they get off their butts and correct that, cause that is mediocre.

Kingslayer
Level 3

I have the same issue. From what I gather since I've seen videos of people using Link with Eye tracking is should be supported.

I've noticed that in the OVRManager component you can set the Movement SDK functions to REQUIRED and then tick all the boxes under "Request Permissions On Startup". If you then generate an Android manifest using the Oculus top menu bar you get a manifest that has these permissions and feature requests in it (similar to the one posted above in this thread).

This still doesn't work though, despite all the requirements outlined in the Movement SDK guide is fulfilled.

I did notice now though that my Quest Pro never prompts me for the permissions when starting the app. I've tried uninstalling the app and renaming it but still it just starts it without any permissions dialogues. I suspect this is the source of the issue but there's not way to tell.