Showing results for 
Search instead for 
Did you mean: 

No Developer Mode on Quest or Rift


Been trying for 7 days now- numerous emails back and forth with tech support


1 Quest 2

2 Rifts



About ready to give up.   Was going to teach VR with Unity and Oculus,  but only thing students have learned so far is that if you want to be a developer then probably best to buy a different headset.  Other companies simply enable developer mode - not tied into Facebook.




thanks for the reply I did sent you a private message to show you my issue


Still does not give me developer option.  And no more response from tech support

Honored Guest

I am experiencing the same issue. My account has been validated but cannot unlock developer mode for the Oculus Quest 2 from the app.
So much for the metaverse ahahahahah

I solved my issue by only using the ODH and buying a Bluetooth adaptor for my windows 10 PC that solved my issue and now I can enjoy the developer mode settings!

I have a Iphone so no such luck.  Hopefully solution coming soon

Retired Support

Update 11/15: We have received reports that this issue has been fixed for most developers experiencing this issue. Please log out and log back into your Oculus app and try enabling Developer Mode once more. If you still experience the same issue, please reach out to our team at (click "Contact Us") and we'll dive deeper.