Showing results for 
Search instead for 
Did you mean: 

OVR Metric Tool v1.6.1 has memory stats unavailible (crossed out)? How to enable?

Level 3

I have been using OVR Metric tool to help me profile my memory usage. I noticed it displaying zero for that metric on 1.5.1 so I updated to 1.6.1 but now it seems those stats are no longer available? How can I view memory usage in the new version?



Level 2

bump. I noticed this as well.

Level 4

Not sure if this is a Quest 2 issue. Worked fine for me with 1.5.2 on Quest 1, now I tried 1.6.1 on Quest 2, got the same (greyed out, so can't even select it). So I downgraded to 1.5.2. That lets me select those but it always shows 0. That's not helpful.

Ok, looks like the Meta update broke it: Still had the Oculus logo on my Quest 1 last time I checked and it worked, now I have the Meta logo on my Quest 1 as well and I can no longer track memory with the OVR Metrics Tool.

That is really very bad.

Level 4

nm, found the solution: adb shell setprop debug.oculus.enableLiveMemoryProfiling 1

Level 4

Ok, this no longer works with Oculus Quest 2, Runtime Version I updated OVR Metrics Tool to 1.6.2, tried the above command, tried a restart. This is extremely annoying.

Has this been fixed as monitoring memory is a very critical part of my development cycle. I know there are other ways to get it, but OVR Metric showing memory was very beneficial for me.  I wish there was more community engagement when decisions like this were made.  I have not seen a word about this here or over in the Start Discord. It is making me go hmmmm

Has anyone heard anything from Meta on this?



I saw this on the 1.6.2 Release Notes.

"Memory metrics will be gated behind system property debug.oculus.enableLiveMemoryProfiling in future OS versions to save CPU performance"


I guess this is telling us a future version will restore memory usage?  Very odd way to update a feature.  Remove it for months then bring back.  I don't understand Meta.  Does anyone have any insights here?