cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Integration 31.0 Passthrough API does not work

korinVR
Level 5

Has anyone managed to enable the passthrough function?
https://developer.oculus.com/experimental/passthrough-api/

 

I've tried the Oculus Integration 31.0 passthrough sample scenes, but I'm getting the error "Failed to initialize Insight Passthrough. Passthrough will be unavailable." OVRManager passthrough related options are enabled. I confirm I'm using Oculus runtime v31 and OVRPlugin 1.63.0, and the experimental system property is enabled.

 

<uses-feature android:name="com.oculus.experimental.enabled" android:required="true" />
<uses-feature android:name="com.oculus.feature.PASSTHROUGH" android:required="true" />

>adb shell getprop debug.oculus.experimentalEnabled
1

 

It seems OVRP_1_63_0.ovrp_InitializeInsightPassthrough() fails.

51 REPLIES 51

Has anyone had pass through suddenly stop working for Unity builds? I just started developing this weekend with Quest 2. I had a helluva time getting it working, but after finding the adb command and checking everything else, I finally got it working yesterday. I ran one of my builds this morning, it was working fine. After work, I fired it up again and no more pass through. I’ve reset multiple times, running the adb setprop after each restart. Adb returns 1 when I do a getprop. I’ve rebuilt and downloaded other projects that should work, but pass through just wont activate in Unity apps. I can turn it on just fine by double tapping. It’s really, really frustrating. It’s like dev mode in a bad state or something. Logcat throwing ‘Failed to initialize Passthrough’ again. 😞 

I could not get passthrough working no matter what I tried, including all of the suggestions in this thread. The Quest 2 I was using is on runtime 34.xxx, I have another Quest 2 still on runtime version 33.xxx and the example worked like magic. Is it possible your Quest updated its runtime? I am not sure when 34 was released... 

chickO-
Level 2

>stop working for Unity builds? I
me too.

I'm guessing it's probably caused by the V34 update.
https://www.reddit.com/r/OculusQuest/comments/qlxynr/psa_all_arpassthrough_apps_are_broken_on_firmwa...


I'm waiting Unity Oculus Integration update.
I hope this cures it.

Yes, I’m just now realizing it must have auto updated today at some point. I’ve been finding breadcrumbs and clues from different forums/reddits that it was deprecated in v34. I did not see it listed un the release notes, maybe I missed it. Ahh, the fun or working with experimental apis! 😄 hopefully the next release of SDK brings it back. Thanks!

Yes, I confirm: the same apk works well (passthrough is working) on a v33 Quest while not working on a v34 Quest... with the message :

"Failed to initialize Insight Passthrough. Passthrough will be unavailable."

Anonymous
Not applicable

Confirmed -- v34 on device kills passthrough... Actively looking for a solution to this. We had some news from support that there is a v35 on the way?!? that may fix -- details beyond that are not very clear. If anyone else finds a work-around, please post!!! Thanks 🙂 

If I understand the situation correctly - Theres no "fix" and a future update will not solve the problem. If you are using a passthrough app that was created with the "experimental" passthrough sdk (ie, V33), no future Quest update version will display it correctly. The apps will have to be re-compiled with a the PRODUCTION version of the passthrough SDK (v34 or above, which I believe was supposed to be released today, but I haven't seen it yet).

Anonymous
Not applicable

FYI -- for anyone watching this thread, v34 is available -- and Unity "Oculus Integration" has also been updated. Woot! Build a new project and confirmed that passthrough is back baby!! 🙂  Now non-experimental...

 

https://assetstore.unity.com/packages/tools/integration/oculus-integration-82022

KIRUT0
Level 4

works for me but glitchs when too close out of gardian