cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Native CPP development and OVR_SDK_Mobile_1.27.0

Anonymous
Not applicable
Hi,
"here we are again", after much time I am back to ( try to ) develop on the Oculus Quest.

So I spent the whole afternoon downloading / installing / following to a T all the instructions at :


And blah blah and ALL the instructions about how to download/setup/configure the whole world ...

RESULTS :

- when I try to open ( or import a project ) gradle starts "synching" and seems to remain stuck forever then you see this error message :

17:15    Gradle sync started with single-variant sync

17:15    Project setup started

17:15    Gradle sync failed: Illegal char <:> at index 23: F:/ovr_sdk_mobile_new/F:-VrCubeWorld_NativeActivity.iml (7 s 813 ms)

17:15    NDK Resolution Outcome: Project settings: Gradle model version=5.4.1, NDK version is UNKNOWN

17:15    Source generation ended in 140 ms

Despite in the "Project Structure" all the paths seems OK and meaningful.

- Despite the Oculus been recognized bty ADB ( installed its own drivers) , put into "Developer Mode" and "Authorized" I cannot see any way to add it inside
Android Studio ( you mean the only way to load code in is to 'install an .apk' , no real time debug ? )

- Any ( native ) project I try to open/import has the same sort of error and "does not compile into anything" actually I can't even see in the project structure
where the actual folder(s) containing ANY source ( cpp o .c ) at all are .. it's like "there's nothing to compile".

So .. what can I do ?

.. it's .. since Oculus started way back I *NEVER* for once managed to have the NDK / etc. work "smoothly" and once more again not ONCE manage
to have it working first time just following the instructions ...

I am sure that in the end there's some way to make it work but at the moment I am stuck.

Any help would be appreciated.

Cheers.

[edit] - looking around I also tried to change this line in gradle-wrapper.properties as this :

distributionUrl=https\://services.gradle.org/distributions/gradle-5.1.1-all.zip


As by suggestion from a place like this :


But it still does not work and gives errrors.

[edit2] - I tried to use the latest version of Gradle 6.0 ..

And that's all I get :

20/11/2019
21:56    Gradle sync started with single-variant sync

21:56    Gradle sync failed: org.gradle.api.file.ProjectLayout.fileProperty(Lorg/gradle/api/provider/Provider;)Lorg/gradle/api/file/RegularFileProperty; (10 s 252 ms)

21:56    NDK Resolution Outcome: Project settings: Gradle model version=6.0, NDK version is UNKNOWN

So at this point I really don't know what to do.

-- UPDATE --

The saga continues ..

So "wanting to prove a friend wrong" as in "I bet it does not work there as well" I RE-installed EVERYTHING under Manjaro Mate Linux ...

Blah blah blah blah .. all the plugins/etc. blah .. try "Open Existing project" -> BLAM errors NO GOOD .. errors ..

HUM ...

So "after various tries" I may have found something .. now the "absurdity of all this" is Cradle saying things like "OH this path is WRONG, it shuld be like THAT" .. except that IT IS like that and it's also in the correct place ..

However further experimentation ( and many cries later ) I found out that "it works IFF you set the proper bash vars", so unless you really set ANDROID_HOME, JAVA_HOME and ANDROID_NDK_HOME this thing continues NOT to work, it's like stuff that "pretends" to read from files, doesn't and/or relies first on the system vars rather than the content of the config file ?

Finally Cradle, again, was complaining that "the minSDK version SHOULD NOT BE inside the Android Manifest but inside the cradle file instead" .. luckily it applied the fix bt its own and apparently complied one of the samples.

Now if I check my Windows 10 setup I DO HAVE the same ANDROID_HOME, ANDROID_NDK_HOME and JAVA_HOME vars set "in the same locations" but still this does not do the trick in Cradle, also I can "confirm", seeing what it downloads, that it's using Cradle version 5.4.1 ( on Linux ).

Ok now we'll see if I manage to use ADB and pair/autorize the thing form Linux as least, would be something, but then the other thing I have to see if I'll manage to install the VULKAN Sdk on Linux as well.

Needless to say I'd MUCH PREFER be able to work on Win10 than rebooting in Linux.

I'll keep you posted, I hope there's a solution/fix/workaround for Win 10 as well.

6 REPLIES 6

Anonymous
Not applicable
*SIGH* .. any way to have Cradle working on win10 then ?

Anonymous
Not applicable
No one managed to get it working on Win10 yet or it's just me ?

elastic303
Level 2
i'm also stucked with this 😕

Anonymous
Not applicable


i'm also stucked with this 😕



Look .. I tried I got the point for now "It's a waste of MY time to try to get it working on Win10", what I can tell you with "not that big work" is IS possible to have it all working on Linux, it would appear that Oculus "suggest" using Ubuntu, for other reasons I cannot explain "I had to use" Manjaro Mate,  works as a charm.

I DID TRY even with "Corba" ( or how is called ) that "Android development plugin" for VS2017 .. can't make it work, I mean I can get the point "the stuff compiles" but it won't launch for "mysterious reasons" on the Quest nor the Logcat would ever work, I think somewat the Quest-VS-GDB protocol/thing is "broken"/etc.

What I can tell is "following the instruction on Linux, it will work", I have a multiple boot machine when I need to develop for Quest I boot in Linux.

Anyway I AM actually "developing" on Win10, I am basically doing "my own framework based on the ONLY sample available" in Vulkan, I am going to do something for Quest and it's all going to be Vulkan based at least there's the blessing there's that ONE Vulkan sample and it's "quite dense" in fact it packs lot of things at once ( and you can well see the guy was planning some 'extensions' to it that maybe will be never used ).

Clearly IMHO "Gradle on Win is broken" and "by a certain look" it kinda appears that it could be "a string concatenation gone wrong" you can more or less clearly see something it's trying to put up a PATH to some file/vars that gets totally garbage.

Also I really DO NOT understand "why on earth they decided to install all those files/things in those absurd paths in APPDATA" and stuff like that.

Now I am NOT "big Android user", I am used to work on/with Windows tools I mostly work on consoles/PC it's been a few years since I put hands on anything Android again .. I can make CMAKE work , at least make "the basics I need" but that Gradle I think "it's awful" nor the mention "the whole way Android packages things".

I yet have to better understand "how you clone an Android project" I don't undersand why they removed that .bash/.sh that seemed to exists some time ago.

Anyway good luck, if you find something let me know, "last time" I touched Andorid Studio ( yeeeeeuch ) again in Win10 it applied "quite some updates" .. .. .. and nothing did happen .. the problems were still there.

For now, "go to Linux, at least there most things work", trust me you will be able to compile and run on the Oculus.

Besides I think now we are in 2 in the "exclusive club" of "I am doing something for Quest NOT using Unity/Unreal ?" .. I suppose there aren't many people ...

Best luck, if you find any way to make things work let me know, for the moment I am working on the Vulkan framework I am building up, I yet have to "insert" it into the Quest.

Cheers.

sinoth
Level 2
Please see the post here:
https://forums.oculusvr.com/developer/discussion/comment/683575/#Comment_683575

It solved my problem in being unable to compile any VrSample under Windows 10.

AmmarkoV
Level 3
Trying to compile on Win10/Android Studio 4.1.1 having the same problems even when following the unticking of the android experimental checkbox post sinoth posted..
Will try linux android studio now.. ( Btw compiling and uploading a regular NDK android sample works fine 😛 )