cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 - Local Storage Path changed? - Quest1 App broken!

Anonymous
Not applicable
Dear all,

I developed a few APKs that run perfectly on Go and Quest 1.
A Unity video player loads a video stored in a local folder on runtime. For that, I switched the video source to URL and its path to /mnt/sdcard/myfolder/video.mp4

Now on Quest 2, it doesn't load the video! Is there a new path? Or does Quest 2 not accept ARMv7 APKs? The app is running on Quest 2, mind you, but not loading the video - as if it doesn't know where to look for the files.

I hope someone from the Oculus officials can shed some light on this.

Thanks
Felix

32 REPLIES 32

Anonymous
Not applicable

SrEskild said:

I had read problems as well. As I understood my problem was that the Quest 2 is running Android 10 and Unity has some problems with this. So I ended up choosing Android 9 (API 28) and used unity 2019.2.
hope this can help.


Hey there, I tried every possible API versions, nothing worked. Can you tell me, which read problem you solved this way? Thanks!

FlopsiBunny
Level 2

Was this ever resolved? Having the same issue.

Fred.Tretout
Level 2

Hi, i just try to read a file from my Oculus Quest2 with Unreal 4.27.2 (node Open URL)

it works with this line :

file:///mnt/sdcard/MyFolder/MyVideo.mp4

Hope it will help