cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 3 Controllers not registering with A-Frame in WebXR

chrispasley
Honored Guest

This feels like a question that must have an obvious answer, as I have found no one else who seems to have this problem, but as I was attempting to work on an A-Frame project I was really confused why I couldn't get my controllers to give me movement in Immersive.  After beating my head against the wall for a while I decided to go look at working examples and see what I was doing wrong.  In every A-Frame project I went to, the controllers did not work.  Even in Stemkoski's Quest Controller Data example. There was nothing.

I tried my Quest 2.  Works just fine.  I factory reset my Quest 3. Nothing. I tried non-A-Frame WebXR experiences - they all worked fine.  For some reason when I take my Quest 3 into Immersive on an A-Frame project it just doesn't seem to register the controllers.  

I feel like there must be a setting or other strange condition I'm missing, but I'm at a loss.  Any ideas?

 

0 REPLIES 0