cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 3 USB connection not recognized (development)

vrwizard.yt
Explorer

Hi,

I started with the developer instructions, but when I connect my Quest 3 to my USB port, nothing happens. The PC does not give any feedback that a device is connected and the Quest 3 also does not realize any connection.
Also in the Quest 3 Settings, I could not find the entry to enable developer mode. I found it however in the Meta app, but activating it did not make any developer settings visible like it was with the Quest 2.

My developer account is set up and verified according to the documentation. I also developed with the Quest 2 before.

I also tried the Quest Link (with the official cable from the Quest 2), but again the cable connection did not work. Air Link works fine via WIFI though.

Am I missing something? Did I miss installing a Quest 3 PC driver? Is my USB to old (3.0)? I tried different USB ports, 2.0 and 3, but with no difference.

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

rg.hettinga
Honored Guest

Reboot your Quest 3 headset. Might be necesarry to do it twice but that did the trick for me.

View solution in original post

24 REPLIES 24

og8studios
Honored Guest

I'm having the same issue on the Quest 3.

I have developer mode enabled on my phone's oculus app and have connected the Quest 3 via the Meta Quest Link Cable but don't see the USB connection section. 

Edit: Got the message when connecting with my macbook so I'm guessing it's something wrong with my desktop motherboard

 

 

image_123650291.JPG

Anecronte
Honored Guest

I tried with different USB 3 connections, but looks like only works with USB-C, so the connection in order to popup the message must be USB-C to USB-C.

vrwizard.yt
Explorer

I only have one USB-C connector on my mainboard and it also did not work using this. So far I never  had any problems with USB devices, so I wonder if my PC does not meet the Quest 3 requirements. Changing the mainboard and all dependent components is I big deal, I would like to avoid that if possible.

rg.hettinga
Honored Guest

Reboot your Quest 3 headset. Might be necesarry to do it twice but that did the trick for me.

therealcberns
Protege

Having the same issue with USB C - C connection. On a windows 11, asus prime motherboard. Says USB malfunction

Thanks! Rebooting did it for me. I can now see the developer entry in the settings and when I connect it to the PC it will be recognized. However, my usb connection still is very unstable, looks like my mainboard is not very compatible, probably not providing enough power on the USB port.

virtual_frog
Protege

Make sure you have a high-quality data cable. USB C cables sold as phone chargers might not have the right circuitry to be compatible with the headset.

would the USBC cable that came with the Quest3 work or should it be a better quality USBC cable?

I would hope the included cable works! I don't have USB C on my motherboard (and the included cable is a little short) so I had to use a different cable. Took me a few tries to find one that worked.

In the end I found it more convenient to use ADB over WiFi.