cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 3 and Unreal 5.2/5.3 - Setup

ToInTheHouse
Protege

Hello,

I'm looking to setup everything to work on unreal5 for a VR/AR game.
I just want to be able right now to launch the game in my Quest3 but I have an error when building/launching the app

LogPlayLevel: Error: UAT: ERROR: Stage Failed. Missing receipt 'D:\Unreal\Project\Starter_521\Binaries\Android\Starter_521.target'. Check that this target has been built.

Does anyone have any good step by step tutorial for the setup of android and everything, I think I did it properly but doesn't looks like it 😥

I followed this tutorials:
https://developer.oculus.com/documentation/unreal/unreal-quick-start-guide-quest/ 
https://www.youtube.com/watch?v=xYc2ZpSc7LA
https://www.youtube.com/watch?v=bSS1P_ABamc&t=1259s

None of them are really following the same exact steps unfortunaly and it's for Quest2. 

I've setup everything from Meta Quest Developer (working) I can see my headset and see it cast.
I've installed Android Studio (this is the most confusing things with all the needed version etc...)
I've install Unreal 5.2 and 5.3 and configured 

ToInTheHouse_1-1698071559272.png

 

ToInTheHouse_0-1698071423921.png



But I still get this error and I have no idea what I need to do. Please help 🙏🙏

Thank you SO MUCH!

1 ACCEPTED SOLUTION

Accepted Solutions

BamDelicious
Explorer

maybe:
try min sdk 29, target sdk 32
And use UE 5.2.1 for now, because MetaXR-Plugin is not ready for 5.3 yet 

this is my setup:
https://communityforums.atmeta.com/t5/Quest-Development/UE5-2-1-Had-some-problems-building-to-Quest-...

View solution in original post

13 REPLIES 13

BamDelicious
Explorer

maybe:
try min sdk 29, target sdk 32
And use UE 5.2.1 for now, because MetaXR-Plugin is not ready for 5.3 yet 

this is my setup:
https://communityforums.atmeta.com/t5/Quest-Development/UE5-2-1-Had-some-problems-building-to-Quest-...

sealfoss
Explorer

I don't know about installed editors. Suggest building oculus branch of UE 4.27. Min SDK needs to be 29, target SDK needs to be 32. Make sure you have the correct NDK (25) installed and that you are pointing to it in Android settings.

Thank you! I'll try this 

@sealfoss what version of Android studio you are using? I am working with AS4, but it does not support Android 12. 

ToInTheHouse
Protege

It worked by following Bamdelicious setup. 😁 Thank you for your answers!!!!
You don't need the Android 12L you just need to setup Android SDK Platform 32 + Sources for Android 32, ARM 64 v8a as written in his doc.

You guys rock! Thanks again @BamDelicious / @sealfoss 

vacuu
Explorer

Any idea what made the difference? I still have the exact same error even though I (think I) did everything mentioned in the guide?!

ToInTheHouse
Protege

I changed settings for:  
- min sdk 29
- target sdk 32

Bbut also really downloaded everything from AS4 that is needed the Android SDK Platform 32 + Sources for Android 32, ARM 64 v8a.
I also need of course the occulus app but also steam vr... Everything together made it worked.

I double checked, everything configured the same (even though I don't get why you would need steam VR?!)

vacuu
Explorer

So I've found a/the solution. I've had to change the following setting:

Editor Preference - Level Editor - Play, Play on Device, check your “Build Game Before Launch” settings, try “If project has code, or running a locally built editor” or “Always”

as described in here