Showing results for 
Search instead for 
Did you mean: 

RenderDoc for Oculus showing black screen when launching

Level 3

I am trying to do some profiling on a Quest 2. I am using RenderDoc for Oculus v25 (latest) on a very simple app built in Unity 2020.3. Yesterday, I was able to connect to the app through RenderDoc for Oculus and perform a capture. Today, without changing anything, I get a black screen after the unity logo startup screen. RenderDoc for Oculus shows it is connected to the Quest 2 in Profiling Mode. After I launch, the RenderDoc windows shows the connection as "Established" and the API feedback says it is Active for a few seconds and then falss back to Not Presenting.


I have tried:

  • Restarting my machine
  • Reinstalling RenderDoc
  • Factory resetting my Quest 2
  • Rebuilding and reinstalling the app
  • Removing the renderdoc packages from the device and allowing renderdoc to reinstall them

I'm out of ideas. The logs also don't show any relevant errors.


Level 2

I have the exact same problem here (Unity 2020.3, RenderDoc v25). The app works fine when launching without RenderDoc. If launching it using RenderDoc, I get a black screen and nothing is capture.

Level 3

the problem solved?