Showing results for 
Search instead for 
Did you mean: 

Trouble Getting Room Setup to Work with Unity


I followed this tutorial which is pretty extensive to getting room setup data in Unity.


I downloaded the github repo with the exact same Unity version, and the room setup does NOT work with Quest Link.


What I see is always a random Room prefab model popping up instead of what I have scanned in my headset.

I have tried deleting my room setup and creating a new one, resetting the boundaries a few time, still no luck.

I'm using MQDH 4.6.0 and just downloaded the project from this github which was linked in the youtube video. 


Here's what my scene looks like:


This is when I have Quest Link turned on and my headset connected. The passthrough is working but I just see a random room's prefab instead of my actual room's prefab.

When I build the project, I still don't see Room Setup data, but I do see a mesh of my room which means something is working:

Screenshot 2024-05-16 205704.png


Can someone with the understanding of how Room Setup data gets passed into Unity tell me what could I be doing wrong? Running out of ideas here. Please help.... it would be amazing to get this working (pleeeeease) ❤️


I found this one post where people mentioned the condition of lights has something to do with whether room setup can work, could my PC's ram and CPU also affect this? (doesn't explain why export also doesn't pull the correct room setup data thou, v confused)




I figured it out!

I had to reset my Quest Link app and re turn on 'Allow Spatial Data over Quest Link' option, now it just works, woohoo~ yayyy


I'm having a similar issue. I tried your steps but its still not working. Can you elaborate more please? What do you mean by "reset" the quest link app? I did reinstall it and turned  'Allow Spatial Data over Quest Link' off and on again.

did u get the Quest Link app to display in your quest?


yes, quest link app is working as expected.

did ur unity app and passthru display properly?


yes, passthrough is working as well. Just tried v64 again and the scene mesh is working. With v65 it doesn't.

I have the exact same issue. Can you please explain what you mean by reset the link app?