Showing results for 
Search instead for 
Did you mean: 

Trouble with developer mode

Level 2

I have had trouble turning developer mode on, on my Oculus quest 2. I have made an organization like 8 to be exact but it doesn't give me on option to turn on developer mode on the oculus app. After linking my oculus up, It just says get started but I've already made and organization and I'm signed in on my meta account we're I made the organization. this is we're I made an organization If you have a solution please reply to this comment it would really help I've been working on this for 3hrs. I just want to be able to turn on developer mode on.



Level 3

...Yesterday was Thanksgiving. Also, it's only been August since Meta started urging Oculus device users to create new Meta logins which will be mandatory on New Years.

...Still... Get on the ball on this!

For me, the phone app just locks up and says it is pairing with my Quest 2 -FOREVER, but apparently never succeeds!

We are all totally unable to use Sidequest because of this nonsense! Do you guys realize what that means?

I'm set up as developer, supposedly, after using my PC to give a credit card. Does this mean my Quest 2 is now in "developer mode", even though the phone app is currently useless in telling me whether I am or not? Sidequest still says I am not in developer mode.

Don't you dare tell me to factory re-set my Quest 2! It is bad enough not being able to access it from Sidequest now. There is no way I am going to lose all the stuff I set up on the Quest 2, before this nonsense started, by doing a factory reset!!

...This is not to harass Meta, but I gotta continue... There was another thread last week about this, so it did not just start on or about Tuesday.

Also, I found chats complaining about "developer mode not working" from way back in 2021, and I saw no indication those problems then were ever fixed!

And one more thing... I tried to set up two-factor authentication for my new Meta login, by giving my phone number. -You guys say you sent a text, so I can verify the number. I do not get these texts from you! It is not AT&Ts fault, because I get texts from my bank, etc. for two-step authentication. I don't think you are really sending a text to me.

...Again, I am not saying this to harass, but please, Meta, get your act together.

Level 3

Since I can't use Sidequest because of this "developer mode" fiasco, what about using Meta Quest Developer Hub to connect the Quest 2 to my PC with USB cable?
That is not working either... When it is working properly, a popup should appear in the Quest 2 asking me to ALLOW access. Instead, I saw a tiny popup that only lasted a few seconds saying something about the login PIN not being right or something. Sometimes even this does not appear, and it is too brief to read what it says when it does appear.

Again, I see evidence from chat forums that other people are also not getting any prompts in the Quest 2 to allow access from a PC via USB, even though everything is setup properly.

We can assure you that you and everyone else experiencing this issue are being seen and the issue itself is being looked into. While a Factory Reset might not always solve the problem, it does tend to help more often than not. Enabling Cloud Backup will also ensure that you don't lose everything.

As for Sidequest, that is not something Meta Quest supports, but we're positive someone here in our lovely community will be able to shed some light on that.

Level 3

Same here, Developer Mode not working. What is happening with the Q2 after Meta merge?? Noticing small issues here and there.

Level 3

I ended up doing a system restore on my Windows PC to a date prior to the latest Windows 11 update. After the PC rebooted the Oculus Developer Mode worked again. I know this is just a temporary solution, but if it helps anyone give this try.

(I'm on Win 10)

Level 3

Yesterday nothing else was working, so I finally resorted to doing factory reset on the Oculus 2. Immediately, the phone app was finally able to pair with the Quest 2, I was finally able to switch developer mode on in the phone app, and Sidequest finally works again.

I am VERY unhappy that factory reset was required, because I lost a lot of stuff I will need to re-create now.

Let me talk about that now, as a lesson learned...

Ultimately this is my own fault, as another example of the old problem of not personally taking charge of ALWAYS backing up my own personal stuff.

I could give lots of reasons why I am mad at Meta for this, but that all is secondary to my own failure to abide by my own hard-learned practices of backing things up carefully and often.

To TinyAngryPanda

( Meta Quest Support 😞

Well, the good news is I FINALLY got the Quest working again but ONLY after a FACTORY RESET!

I know positively that cloud backup was ON before all my problems started.

I DID lose everything! That "Cloud Backup" link in your reply takes me NOWHERE, because the instructions there under "View apps supported by Cloud Backup" are WRONG!

Here is JUST ONE of the big problems I now face:

I had the Wander App that I already bought and paid for early in 2022. It is no longer on my headset. All I can do is go to the store and BUY IT AGAIN!

I also DO NOT HAVE unlimited bandwidth, so it will cost me data fees to re-download all the apps that are gone now, because Meta screwed up my Quest 2 forcing me to do the factory reset!

Level 5

Retweet this! Hopefully we make enough noise!....