Showing results for 
Search instead for 
Did you mean: 

UE app won't start on quest2

Honored Guest

i am trying to testbuild an app on linux using UE, following this tutorial with the VR template   , using metaXR downloaded from here which runs into 2 errors coz 1. some .h files are not where they are supposed to be when a xxxwrapper calls for them, easy fix thx to cahtGPT = find them and bring them where they have to be, 2. error when trying to copy a file into the project folder coz the ThirdParty folder in Marketplace has a small 'p' , fixed that too, packaging completed, installed on the quest but wont's start, gets stuck forever in the 3 dot loading screen...

when i disable metaXR and package with openXR all is fine... tried to use only meta without openXR in case that's the reason but it won't work as metaXR enables openXR...

i know i can just use openXR but this is meta so i would like to use metaXR, and btw guys, don't you test things before you release them? i mean this is really... 

coz if you test those things then you would run into the same problems and fix them, no? 

tried UE5.2 ,latest current stable 5.1.1 nothing...

4.27.2 without meta but oculusVR works fine...

when the app starts with openXR it asks for some permission, so i thought maybe that's the reason it won't start but i am too much of a novice to be able to look into it...


I'm also a complete noob, so take what I say with a pinch of salt. My investigations (primarily from the github fork of Unreal made by Meta) seem to suggest that MetaXR is simply not supported for any OS other than Windows. Even that was confusing as the repository readme for the main Unreal source was appended below which gave instructions for installation on Windows, Mac & Linux. I bought an SDD, installed Windows so I can dual boot and I seem to be making (admittedly slow) progress now and have eventually been able to install the sample projects onto my Quest from Unreal 5.1.1 and make tiny modifications without everything crashing. It has taken about 3 weeks of discovering all the hoops that need to be jumped through as the information is scattered between tutorials by Jonathan (GDXR) on youtube and various pages. I had similar grief when I started writing apps on my phone.

Honored Guest

thx man 🙂


yeah that would make sense, and i have seen this also when i tried their forks, but then i thought how can this not be supported on linux when as you say you can build the engine on linux...

but after trying so many branches and so many installations, i am at the point to just give up and work with the openXR since meta in general seems to snob linux as there isn't even a hub or oculus app for linux, which is pretty mind blowing to say the least, but i love linux and don't wanna go back to windows anymore, so i saw now there is a brand new v51 that came out yesterday, installing once again 5.1.1 on zorin right now, but if this also fails then i will stick with openXR and start taking some courses to learn some dev coz i already wasted enough time...

i also watched a few videos by jonathan, followed along but same result, just won't work, i even joined his discord but the other day i found out that he is selling his VR template for a crazy 50 + euros so that was it for me, bye byeeee lol

do you have any suggestions for good VR courses for unity or UE? 

i bought on udemy the gamedev courses for UE4 and 5, also their VR course, joined now on coursera a course from university of london, saw unity has their own courses on VR, so that's what i found as best til now, but i am open to check others out too if they are good...


thx for your help 🙂

I think Unreal are trying to support Linux (although I have seen on other forums people asking if anyone is actually successfully using it on Linux because it is so crashy). My own experience with Unreal on Linux was that I was missing some patch for glibc on Ubuntu 20.04 that means it takes 20 minute to get to the screen to choose which project to open, then another 20 minutes to open the project. If it crashes a minute later, great anger ensues. I can't upgrade to 22.04 (which apparently fixes the load time issue) because of other work commitments. It is Meta who are keeping MetaXR as Windows only.

Sorry I can't help you with course suggestions. I am just trying to extract the hand and face tracking numbers for scientific research. No-one seems to want to do anything like this so I struggle to find any useful resources and just stab at buttons until something happens. I am not looking forward to the file writing, UDP streaming, bluetooth triggering and cloud comms I have to work out next.
I am avoiding v51 for the moment as I only just got things working and I am too scared of what the new version will break. I would probably not be able to fix it.

Honored Guest

oh, i didn't even know there were loading issues as i am just playing around with it for ca 2 weeks trying different distros and all were fine with opening UE and projects, no problem, just very 1st time after building the engine it takes some time but after that it's pretty fast, and i tried with mint, ubuntu, kubuntu, now zorin, so all ubuntu/debian based as for some reason i couldn't even manage to install centos and manjaro had other issues, but once i installedthe OS everything works fine except the metaXR, so once my engine finishes building i try 1 more time and then no more metaXR, my patience is finished lol

good luck with your project and research, and thx again for the help 🙂