Showing results for 
Search instead for 
Did you mean: 

Unreal Multiplayer issue Joining Session

Level 4
Hi, I've posted this on the Unreal forums as well so if I get an answer there I will post it here. I've been developing a VR demo in Unreal 4.22 for the Quest for about a month with great success. It is a multiplayer shooter and I've been hosting on the Quest or Vive and have tested with 4 players, everything's great, until... Randomly about a week and a half ago, for some reason the Join Session node is not allowing the client to connect to the listen server anymore. When the client calls Join Session after finding the server, the Join Session node fire off and complete off the success pin as if everything is fine! except nothing happens...  I also setup a test in 4.23( of course following the instructions on this site) and am experiencing the same issue or issue where I connect to the listen server but it isn't the same instance of the server as the players cannot see each other inside the level. Has something changed recently regarding networking on the Quest? Is anyone else having multiplayer issue in Unreal recently? I feel like something changed and I just don't know about it.

Level 5

Join Session still not working after removing steam vr and steam advanced sessions and making sure the project matches the dependencies for .uproject and .ini files etc.. from unreal sample but using OSS oculus bp and join session doesn't find the correct map on the host VR headset still over matchmaking pool but its always joining but not traveling even with turtle rock fixes applied and all sorts of crazy setting changes

Level 3

Hello everyone.


Has anyone happen to make this work? I've been trying to make this work for about 2 weeks and I'm still in the same spot: I can create a session, a client CAN find that session but CANNOT join it properly. If I build using the installed version of UE 4.27, the client joins the session, but it just stays there waiting, no travelling to the listen server map. If I build using the UE 4.27 source, the clint finds the session, but when trying to join, it crashes...


I also tried modifying the OculusNetDriver.cpp and IPAddressOculus.h, but there is no difference.

It's making me crazy jajaja



Level 4

Hi, try my solution for this. Waiting for being approved by oculus but helped many people (including myself xd).

Didn't work.


I included this line in the AndroidEngine.ini in Config\Android



and it stopped crashing, but it won't travel to the server's map.

Were you ever able to get this working? I've also been trying for weeks now and am starting to think it's not possible in 4.26