Showing results for 
Search instead for 
Did you mean: 

User files with multi-user accounts


How can I read/write files from/to the device while logged in as a secondary user?

I currently write logs as well as user-generated content to Unity's Application.persistentDataPath, which comes out to be under:

Quest\Internal shared storage\Android\data\com.MyStudio.MyGame\files\


However, when logged in under a secondary user account, I can't seem to enable the ability to browse files on the device using a PC, so I can't gather any debug logs I've written to debug issues while logged in as a secondary user. If I log back in as the primary user, I only see logs, and user-generated content written to the above location by the primary user. No user-generated files by the secondary user appear. But when logged in as the secondary user, I can see their user-generated content, but not that of the primary user.

It seems each user somehow has their own data folder, but I can only access the primary user's data via a connected PC. And if I want to manually place data files into the folder via PC, I can only do that for the primary user, not the secondary. 


So I either need to know if it is possible to read and write files to/from the device while logged in as a secondary user, or if there is another protected common storage area I can read/write from/to that can be accessed by any account logged into the device?





Also would very much like to know how to do this for different reasons. I've noticed Secondary Accounts can play AudioShield but can't access the folder where my custom songs are located. They can even download songs through the browser, but I can't find that location from the file explorer on my computer, and I can't find it from my primary account, like it's somehow encoded in to a state that is externally unreadable.
I don't want to download them all again for the time it would take and the space it would take.
(So, not nearly as big a deal as your problem, but just to add some love to this thread and add to the reasons to fix it.)

Honored Guest

I just ran into the same problem. Did not find a solution yet, sorry. There is no approval request for data access when connecting USB on a secondary account.

Some reddit user suggested it's connected to Oculus TV, which seems also unavailable under secondary accounts.

The solution suggested did not work for me, since I could not uninstall Oculus TV, which is a part of Oculus Home.

Honored Guest

I've just run into the same issue as OP.


Has anyone managed to figure out a way around this yet or if there's been any official word on when the multi-account functionality and file access to non-primary accounts will be fixed?

Honored Guest

I’m also in the same boat. 

recorded a 30 min video on a shared account and now cannot access it via PC. It’s really lame that we are restricted so much when it’s our own device. 


I'm having the same problem when my partner recorded a Beat Saber video on her secondary account.


On my account (device owner) we can access the headset on Windows 10 but none of her files show up in the folders, I assume for security reasons. On her secondary account we can't access the headset at all, so again can't get to the files.


I tried enabling developer mode and added her account as an admin in my developer organisation, she signed up as a developer as well. We turned on the "USB connection dialogue" option in settings, but nothing changed. It's infuriating!! But she can share it to crappy old Facebook that'll compress the hell out of it.

Have you tried uploading to Google Drive or another cloud storage solution through the Oculus browser?


Not a great long-term solution in my experience, but I think it should get you this particular video.

Excellent 😄 it appears to be working, it's uploading at the moment anyway.


Like you say, not the best long term solution but she's chuffed she can get videos now, so all is good.

did this work? if so how? i tried the browser and when im in gdrive it wont do anything when I hit the upload button. no file select or anything.

It worked for me, I clicked the "New" button top left, then "File Upload" and selected the file I wanted. It took a while to upload but it got there in the end.


Maybe the Firefox Reality browser would work better if the standard browser isn't working.