cancel
Showing results for 
Search instead for 
Did you mean: 

apps from unknow sources not showing after updating v54

txvrmanager
Explorer

After updating to v54, my Quest2 no longer shows apps from unknown sources under the "unknown" category。
Previously, I could easily access a list of apps from unknown sources by selecting "unknown" from the filter icon in the App library. However, after the v54 update, selecting "unknown" only results in a perpetually loading icon, without displaying the list. Is anyone having the same issue? I would greatly appreciate your advice on how to fix this issue.

8 REPLIES 8

tylercroach
Protege

I'm not even surprised at this point. Meta has been dropping the ball ever since they fired half of their VR/AR team. First we had to deal with the low memory crashing that gave us the biggest headache thinking it's us and not them, then people were saying v54 breaks controllers and lots of other things, and now we may not even be able to test our app. Hilarious.

Thanks tylercroach for responding!
I see that other developers might have issues with v54.
Hoping Meta will fix the issues soon.

MetaQuestSupport
Community Manager
Community Manager

Hiya there @txvrmanager! We hate to hear that you are having trouble with opening unknown content. We are more than happy to lend you a hand with this. Here are some tips you can try to enable the feature:

 

To allow content from unknown sources:

  1. Open the Oculus app on your PC computer.
  2. Select Settings in the left menu.
  3. Select the General tab.
  4. Next to Unknown Sources, adjust the toggle and then confirm to allow content from unknown sources.

 

We hope this helps. If you continue having the same issue. Please reach back out. We'd be more than happy to continue assisting you. 

@MetaQuestSupport ,  I really appreciate your quick response.

I would like to try the steps you suggested.
However,  currently I do not have a laptop which satisfies the requirements (GPU etc) for running Occulus app for PC.
Does Android/iOS occulus app also implement the feature to allow content from unknown sources?

Morgana
Explorer

I just got auto updated to v54 (thought I'd disabled auto updates 🙁 ).  This had me stumped and I found your post but also found the solution after a bit of clicking around.  If you click the search bar in the App Library window, you can select 'Unknown Sources' again from the drop down.

Hope this helps!

Taivas
Protege

Same here, yesterday it worked, but today it does not. It did a software update in between, it looks like they removed the whole menu about different types of software.

I tried restarting, re enabling dev mode, connecting with ADB, but nada. Someone said I should try disconnecting the battery to reset the device, but I'm not going to risk my device like that.

 

How can i do this from my phone???

Hi, 

I am facing a similar challenge today. I have installed an app and I can see it in the Unknown category under the dropdown in 'All apps'. However, when I launch the app, it just quits and nothing shows. I have followed the steps here and enabled Unknown Sources in the Oculus PC app but it hasn't solved my problem. Any help? 

Thank you.