cancel
Showing results for 
Search instead for 
Did you mean: 

hands not responding as expected on oculus Quest

nirharpaz
Level 3
hello
I'm trying to develop an app to Oculus Quest yet i encounter many issues on the way.
the app basically consist of a room and teleportation.
the issue i encountered happens both on unity 2018.3.12 and 2019.1.8.

I created an app that did work as expected before on Quest using Oculus integration v1.35.
however, when re-exported and installed to a brand new Quest device:
1. teleportation that worked before refuse to work
2. pressing a button on 1 controller hids the other one from view.
3. hands movement is limited
4. even though target devices is set to Quest, i still (on v1.35) see the controller of oculus go
92r57mvy81hv.png
5. it only happens when exporting to quest, on rift it works just fine.

things I tried:

1. Start a new project from scratch:

followed the standard tutorial and documentation like those
https://www.youtube.com/watch?v=qiJpjnzW-mw&t=1s

https://developer.oculus.com/documentation/quest/latest/concepts/book-unity-gsg/

could not see the hands at all, and no teleportation was implemented, it is said that there is a bug in current v1.39
https://forums.oculusvr.com/developer/discussion/79144/hands-not-showing-up-with-localavator-unity

2. I tried to use both the unity OVR assets and the following plugins
https://assetstore.unity.com/packages/tools/input-management/vr-movement-system-for-oculus-47292

https://assetstore.unity.com/packages/tools/input-management/vr-arc-teleporter-61561
and in all 3 encountered the same issue.

did anyone encounter any issue similar to what's described?
as some test, (since i do not have another quest)
i exported a build and sharing here.
please comment if you have tried it and it workd fine on your quest or not
https://www.dropbox.com/s/uvcmhyar2qljb19/k14.apk?dl=0

3 REPLIES 3

dr3d
Level 3
Ditto no luck now making Quest things that I was able to build 2 months ago

Anonymous
Not applicable
Hi there, I've been having the same issue and I am currently in the process of trying this fix: https://forums.oculusvr.com/developer/discussion/79152/project-issues-with-latest-firmware-integrati... If I where you I'd give this a shot aswell 🙂

nirharpaz
Level 3
hi
update 1:
if hands don't appear at all, its because Oculus integration 1.39 is buggy
revert to 1.38
https://developer.oculus.com/downloads/package/unity-integration-archive/

second:
thanks to all the helpers.
the problem is that the latest firmware update added GO  controller support and defaulted it.
so Quest controllers begun appearing as GO
the trick was to copy the AndroidManifest to Assets/Plugins and edit it properly to specifically define the correct settings.
you can see the recommended changes here
https://developer.oculus.com/documentation/quest/latest/concepts/mobile-native-manifest/?fbclid=IwAR...