Showing results for 
Search instead for 
Did you mean: 

set oculus as active openxr doesn't work

Honored Guest

Hello everybody,

I try to click on "set oculus as active openxr" but it doesn't work. I am not an administror user on my pc, I saw that other persons in the same case have the problem. I tried what I saw on the furums : run the Meta Quest Link app as administrator, reinstall the app, turn off then on "unknown sources"... but it still doesn't work.

Could you help me please ?




Expert Protege

I see you were using a Windows Mixed Reality setup before. I used to have a similar setup.

Also, on the screenshot you provided , I can see that the Open XR is still setup for WMR. Did you press the button to change the OpenXR provider? Also, did you restart your PC afterward?

Finally, I suggest you disable your WMR headset in the Device Manager (locate it, right-mouse click it and disable the device). This is fully reversible if you change your mind - just re-enable it.

I replaced a WMR headset with the Quest 3 and, once I changed the OpenXR provider, it worked like a charm. I typically fly MS Flight Simulator 2020 and the Quest 3 is simply fantastic.

Thank you chris.o.yul for your response, finally my supervisors accepted to make my account as administrator of my pc. since that I could select "set oculus as active openxr" and the connection with the headset works.

I still keep in mind your comment for my collegues that could use the quest in the future.