Showing results for 
Search instead for 
Did you mean: 

How to Resolve Failed Entitlement Check?

Not applicable

It appears that our application has failed the entitlement check part in the technical review the past couple times, and we are unsure at this point what we are doing wrong. 
Below we have attached two screenshots that include a screenshot of our entitlement check script, and a screenshot of our OculusPlatformSettings. We placed the script in an empty game object in our opening scene so the entitlement check should happen as soon as the app starts. We would really appreciate any assistance you could offer in fixing this issue, as we have gone through the documentation and can't figure out what the issue in our entitlement check is.

Edit: Added to RC channel and tested out. Works now.


Hi @imperativity.

I would need assistance. Can you give me a bit context. I have the exact same issue as OP and i cant figure out what to do now. I see comments "add it to RC channel" and it will work.  But i want to submit my app to store. I cant do that trough RC channel? Can i? 
I have my entitlement check working (my code is near identical to OP example) and it is super frustrating that i get keep failed on that check while the exact same app as a standalone windows version passed the check and was accepted to a store exactly 45 days ago.

Please help me, or at least help me understand the problem.  What am i missing here?
Many thanks,

This is Gear VR application. 
Just in order to be more clear, i will write everything down.

First we made a Rift app. Had entitlement check requirements all filled. Submitted to the app store and it was accepted.

Now we have GearVR version of the same app. Submitted to the store and got rejected with a message
"It appears that your app does not support entitlement checks to prevent unauthorized use of your content. Documentation on how to add entitlement checks can be found here:"

Went trough the documentation and double checked everything. Could not find any issues.
Came to dev forum and found many threads about the same issue. (or i at least think it was the same issue since they described the same error).

What was confusing to me was reading "this is a known issue, upload it to RC channel to bypass the entitelement check" that was mentioned in older thread. 

So i had hard time putting things into context. I have nothing to do with RC channel. I want to submit app to the store and dont know what should i do. Has something gone wrong on my end and my entitlement check really fails or is this a somekind of bug on submission side and i have to do some magic on RC channel.

Hope it is more clear. Would like to get it resolved.
Tried an email to oculus submission but got an answer along the lines that they are unable to help me and i should be seeking help on dev forum.


Hi. Any change to get your input today about this issue. Did my explanation make sense? Any suggestions what i should do?


Thank you for the answer. I am familiar with that documentation. I used this when i made a Rift version of the app.
I am sending you rest of the info via PM.

Honored Guest
Hi. Even though i follow all the docummentation and the tip on putting a build on the RC channel i still get the entilement error. Can you @imperativity take a look on what is going on... app link