Showing results for 
Search instead for 
Did you mean: 

New build not updating in Oculus store (Gear VR)

Honored Guest
Hey guys.

I've hit a bump here, that have caused me some confusion.
I've successfully uploaded a build to an alpha channel, and added a few testers, myself included.
Now I've updated the build a couple of times, and re-uploaded it.
When I go to the Oculus store, and run the game, I'm prompted to update to the newest build.
But when the update is finished (100%), for some reason I still have the old build, and the update prompt is still there.
I've tried updating in the headset, and in the on-screen Oculus Store app - but with the same result.

Am I missing something?
Do I have to do something more than just uploading in the Dashboard?

Honored Guest
UPDATE: Seemingly I'm also not able to Uninstall the app again.
Could the issue be, that my app doesn't have a write permission in the manifest?

Honored Guest

I have the exact same issue, did you find an answer ?

Honored Guest
UPDATE : for those in need, i used adb uninstall, and it worked just fine