Showing results for 
Search instead for 
Did you mean: 

ovr-platform-util.exe fails with error "A server error occurred. The request will be retried."

Not applicable

For the past couple of days, I've been unable to upload builds to the Oculus backend using ovr-platform-util.

The following stages succeed:

- Starting upload for app: xxx
- Finding files...
- Validating package...
- Deduplicating segments:
- Submitting segments:

But the last stage "Submitting upload..." loops on the following error: "A server error occurred. The request will be retried."

I'm using ovr-platform-util in version

Is there something wrong on the server side?


Level 7
Same. Pretty sure it's a server issue.

Retired Support
Thanks for the heads up. I've notified our engineering team and they've pushed out a fix for this. Please try once more - if it still doesn't work for you, ping me and I'll take a look.
If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
2. Please submit a ticket here through the "Contact Us" link (include what you've gathered in step 1).
3. Tag me @mouse_bear once you have done so!

Not applicable
Thanks @NinjaGaijin,
I just tried uploading again and it failed with the same error. I'm sending you the associated log file via private message, it contains a stack trace that might help you investigate.

Level 2
Hi, I have this issue too, can you help solve it?

Level 4
Hi @NinjaGG , same issue here. As soon as I hit the upload stage, I get "A network error occurred. The request will be retried." over and over. Another post said to just let it run and ignore the errors but I ran out of memory. The detailed logs say:

2020-11-12T03:14:02.469Z [ERROR] Server log: {"app_id":<redacted>,"log_level":"ERROR","event_name":"NETWORK_ERROR","stack_trace":"Error: read ECONNRESET\n    at TLSWrap.onread (net.js:622:25)","extra":"{\"options\":{\"method\":\"POST\",\"url\":\"\",\"qs\":{},\"formData\":{\"upload_session_id\":\"<redacted>\",\"start_offset\":\"110000000\",\"chunk\":{\"_readableState\":{\"objectMode\":false,\"highWaterMark\":65536,\"buffer\":{\"head\":{\"data\":{\"type\":\"Buffer\",\"data\":[<a lot of data>

Level 2

Also getting this issue "A server error occurred. The request will be retried." Is there a solution or is the solution just wait for servers to respond again?


Level 3

We are also experiencing this issue. All uploads were fine until last night.
This is the error we see in the log files
"app_id": xxxx,
"log_level": "ERROR",
"event_name": "API_ERROR",
"stack_trace": "at [eval]:80:3679\nat p ([eval]:9:419)\nat Generator._invoke ([eval]:9:1723)\nat Generator.t.(anonymous function) [as next] ([eval]:9:841)\nat n ([eval]:78:82)\nat v ([eval]:78:292)\nat [eval]:78:351\nat new Promise (<anonymous>)\nat [eval]:78:233\nat Object._log ([eval]:80:4054)",
"extra": "{\"response\":{\"error\":{\"message\":\"Parameter obb_binary_id: Invalid id: 0\",\"type\":\"OCApiException\",\"code\":100,\"fbtrace_id\":\"AHZEtc-k0WMVuw_bKIif5Jv\"}},\"options\":{\"method\":\"POST\",\"url\":\"\",\"qs\":{},\"formData\":{\"app_id\":xxx,\"asset_file_..."}"

Level 2

Sane error here: "A server error occurred. The request will be retried." 9 times and finally "ERROR: An unexpected error occurred"

Level 4

Getting the same error here.