Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

DK2 working again with an update, Thanks Oculus!!

Level 7
I would like to take the opportunity to Thank Oculus for bring my DK2 back to life. I believe there was an update restoring the DK2 and thank godness the good folks at Oculus have provided the DK2 with functionality again it was just a pretty looking box for a month or so πŸ˜„

It really is a good machine and i for one am thankfull

Level 5
That's awesome but strange considering they never mentioned it, anyways I'm jealous of you even getting the 1.10 update yet 😞

Level 4
I've never had a version since 1.3 which was not compatible with my DK2. Every version worked, aside from the IPD adjustment which is not available in the new software.

Level 11
I just messaged my buddy who has my DK2 to see if he had any problems with any of the updates.  I'll let you know what he says.
Any sufficiently advanced technology is indistinguishable from magic. - Arthur C Clarke

Level 5
My Dk2 hasn't had any issues with any of the updates.

Not applicable
You were able to use the DK2 even if you didn't have usb 3.0. Than 1 update made it so apps wouldn't launch. Not sure if this is what the OP is referring too.

Level 7
ooo man i spoke to soon..I installed Oculus setup and it worked with the DK2 then it started updating again now same problem as before it definately not a hardware issue but it does seem the check after update does looks at pc spec, and if they dont quite meet expected the ocilus interface simply disappears..which is a bummer as it is not even a CV1

Level 7
They just fixed it..DK2 is back ladies πŸ˜„

Level 5
i've been able to plug mine back into USB3 and the disconnects don't seem to be happening.(Every 30 seconds before.. i had to use USB2 and nothing in home worked.. steam VR was fine though lol) I wonder if this is a coincidence or is there a fix in here for that?

Level 7
it probably is a way everyone with a DK2 is all of a sudden back lol