Showing results for 
Search instead for 
Did you mean: 

Judder caused by camera! SOLVED!

Honored Guest
edit: SOLVED!
Plug the AC power adapter in!

If you are experiencing vertical juddering, try attaching the included power adapter, even if you aren't using the Rift's usb port. Thanks to everyone's suggestions I went for yet another round of troubleshooting my judder issues. After trying a few other suggestions I finally tried plugging in the power adapter thinking "maybe my USB 2 ports aren't pumping out enough power." Bingo, that did it. Again I set my rift on a steady surface and loaded up every demo and it was totally smooth and judder free. I still have other stuttering issues when moving my head in some demos/games but these are most likely attributed to frame rate issues in most cases.

Thank you all who replied with suggestions! I hope this solves some other peoples judder issues as well! Spread the word! Plug in the power!


I've been looking into why I'm experiencing judder (aka jitter; aka a slight shaking of the video while the hmd is not moving) and I think I have narrowed down the problem to the Rift's camera. The judder is present in all demos/games and even in the oculus desk demo. The judder does NOT seem to be caused by low frames, the in game FPS hovers around 75.

I set the rift on a stool in the camera's range and watched the video on my monitor where I could see the juddering. Then I simply cover up the camera with my hand and the judder immediately stops; the video is perfectly still. (I get the same results in Direct mode as well as Extended)

While wearing the rift I also see the juddering until I cover the camera with my hand, I immediately lose positional tracking but the juddering is gone entirely. This is the same experience I have in any demo/game.

Does anyone have any suggestions for what I should try to fix this issue?
Is it possible my camera is faulty and should be replaced? Are there any other tests I should perform to further narrow down the issue?

My graphics card is a bit dated but frame rate doesn't seem to be the issue for the simple demo's I've tested with.
My Rig:
Intel i7 - GTX 560 Ti 2gb - 6gigs ram - win 8.1 64bit - usb2

Rising Star
Interesting question and I wonder is the extra processing required by the positional tracking of the camera is having an impact on your video rendering ? The 560 maybe just doesn't have enough grunt for VR ?

"blanes" wrote:
Interesting question and I wonder is the extra processing required by the positional tracking of the camera is having an impact on your video rendering ? The 560 maybe just doesn't have enough grunt for VR ?

Yeah but people with 780 Ti OC and such also report non-framerate jitter.

If it's caused by something to do with the camera it could be producing a bit of error into the positional tracking in a repeatable way.

Not applicable
I always sorta figured it was the camera that caused the weird jutter in all of the videos that I watched, but I never said anything about it. Seemed kind of obvious, I'm not sure why nobody brought it up. It's likely something fixable in software, the same way that they used prediction and smoothing in the rest of the head tracking.

Oculus has said that it's a driver issue and a fix is forthcoming. Be patient!

Honored Guest
I have a 560Ti as well, but the desk demo and unity tuscany are super smooth. CPU is a i7 3770. I'm even able to get playable results in Elite Dangerous without dropping settings too much(just disabling shadows). Sightline and a few others have unplayable levels of judder however.

Some judder is not caused by the camera. My judder occurs whether I have the camera active or not. See this thread: viewtopic.php?f=34&t=12335
Brad Davis - Developer for High Fidelity Co-author of Oculus Rift in Action

I have the exact same problem, but only since updating to 0.4.1. I get microstutter in all demos, including the Oculus desk demo. As soon as I put my hand over the camera and thereby lose postitional tracking the stuttering problem is gone. Usig Win 8.1, r290. Unplugging all usb cables and reinstalling the runtime driver and then putting the cables back has not helped. Strange thing is, the problem wasn't even resolved after going back to the 0.4.0 runtime or after a system restore, so it could have just been a coincidence that this problem appeared after updating to 0.4.1. Either way I really hope this is fixable soon. I'd rather do without positional tracking for a while than having this headache inducing microstutter all the time.

At least it's good to know I'm not the only one having this problem!

Honored Guest
One fix I saw was create a shortcut to the DirectToRift.exe of the game you're using and add the following to the target in the properties:

"GameDirectToRift.exe" -force-d3d11

Obviously requires DirectX 11 installed and a compatible graphics card. This reduced some of the juddering on some unity demos I've been trying.

I just tried a program that had bad vertical judder and it disappeared completely when I disabled timewarp in that program.