cancel
Showing results for 
Search instead for 
Did you mean: 

No HMD Detected on Macbook Pro Retina 2013 + macOS High Sierra + DK2

rachapong
Level 2
I have quite an old system but want to work on this setup for experimental.
However, I cannot make them work together. Please kindly shed me some lights if you have any.

HW: Macbook Pro Retina 2013 
OS: macOS High Sierra
Oculus: DK2

Reproduce Steps
1. Installed Oculus Runtime for OS X
2. Plug-in USB and HDMI from Oculus into Macbook
3. Ensure the Oculus power is on (Green light)
4. Start RiftConfigUtil.app
5. It always shows "No HMD Detected".

When looks at the log file - OVRServer-out.log, I found this message
[OSX DK2 Cam] CameraFrameNotification: Empty frame reported, terminating reception
[OSX DK2 Cam] CameraFrameNotification: Empty frame reported, terminating reception
[OSX DK2 Camera] Camera thread terminating.
[OSX DK2 Camera] Closed camera device.OVR::DeviceManager - shutting down.
This is the Diagnosis Log.
{
"Time": "2018-06-09_23:05:25",
"SDK Version": "0.5.0.1",
"Service Protocol": {
"Major": 1,
"Minor": 3,
"Patch": 0
},
"RemoteProtocolVersion": {
"Major": 1,
"Minor": 3,
"Patch": 0
},
"Service Running Time": {
"Hours": 0,
"Minutes": 0,
"Seconds": 18
},
"System Specifications": {
"Operating System": "Version 10.13.4 (Build 17E199)",
"Total RAM (GB)": 8,
"Processor": "Intel(R) Core(TM) i5-4258U CPU @ 2.40GHz",
"Video Controller Name": "Intel Iris"
},
"Devices": []
}
-----
What I have tried but still not get better results
1. Re-install Oculus Runtime
2. Restart Macbook while USB and HDMI connected
3. Unplug / re-plug in both USB and HDMI
Kindly appreciate your suggestions.
2 REPLIES 2

Hiro_Protag0nist
Level 13
What graphics card is in that?

rachapong
Level 2
It is Intel Iris 5100.
The captured details are below.
Intel Iris:

  Chipset Model: Intel Iris
  Type: GPU
  Bus: Built-In
  VRAM (Dynamic, Max): 1536 MB
  Vendor: Intel
  Device ID: 0x0a2e
  Revision ID: 0x0009
  Metal: Supported, feature set macOS GPUFamily1 v3