Showing results forย 
Search instead forย 
Did you mean:ย 

Oculus USB 3.0 Issues RESOLVED

Not applicable
I kept getting an Error message telling me I had hardware issues with
my Oculus Rift Sensor and headpiece. The solution is as follows.
*Unplug ALL Oculus cables from your PC
1. Uninstall All Oculus software in "Programs" of the Control Panel.
2. Uninstall All Oculus software in Device Manager of the Control Panel
Locate the "Search" box in Windows and type   %APPS%    Delete ALL
instances of Oculus in ALL categories. This will clear out all cached data from the initial Oculus software installation.
4. Order a Startech USB 3.1 PCIe Add in Card from  Use this link to order; 2 Port USB 3.1 (10Gbps) Card - 2x USB-A - PCIe USB 3.1 Card with Type-A - PCI Express - Supports UASP (PEXUSB312A)

5. Install the Startech USB 3.1 add in card into an available PCIe slot. Be sure to connect your PC Power Supply SATA Power Connector to the SATA Power Connector on the Startech card.
6. Go to to download and install the driver for the   PEXUSB312A   card.   Restart PC.
7. Go to   ; Login to Oculus that you initially did your logon to.
8. Completely go thru the Oculus Rift setup procedure again, following the sequence of plugging in the USB 3.0 and HDMI cables.
YOU MUST CONNECT THE  (2) USB 3.0 CABLES FROM THE OCULUS SENSOR AND HEADPIECE TO THE USB PORTS ON THE STARTECH CARD. The Startech card now supplies the proper USB 3.1 configuration and power level for sensor and headpiece.
9. USB 3.0 problems solved on the Oculus Rift!   ๐Ÿ™‚

interesting so the inatek ones they recommend are the problem? 

Not applicable
I can't speak for Inatek PCIe USB 3.0 add-in cards for their effect on resolving Oculus Rift USB 3.0 issues. I did not purchase an Inotek USB 3.0 PCIe addin card. Just stating how I achieved my solution to the problem.

Expert Protege
I have the inotek one and it works fine.  Maybe just uninstalling and reinstalling was enough.

The Inotek one is fine as long as you don't install the Inotek drivers. With the official drivers (which Oculus Home keeps telling me to update to) I get disconnects and the Windows plugged / unplugged sound every now and then. With the generic Microsoft drivers in Windows 10 it works just fine.

Honored Guest
Inatek don't work for me, It recognizes only as USB 2. Tried multiple USB cables that are clearly recognized as 3 on other machines

This is the same exact issue I'm running into at the moment. The StarTech drivers seem to be the problem here -- and are somehow only allowing the ports to output USB 2.0 instead of the advertised 3.1.