cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 doesnt charge or turn on

MaxKiller2006
Level 2

My oculus quest 2 will not charge or turn on in anyway. I have looked throught the internet and have found people with similair problems but without an answer. When i press the power button to turn it on i quickly flashes the meta logo and turns back off again within miliseconds, It keeps repeating if i hold it down.

It also doesnt seem to charge. I have tried all the chargers in my house and still nothing. The light doesnt even turn on to say its charging.

If anyone can help.

3 REPLIES 3

MetaQuestSupport
Community Manager
Community Manager

Hey there, @MaxKiller2006. We know power issues are a real pain, and we don't like when that happens to our users! Not to worry, though; we have a few other tips that you can try.

• Attempt to charge for 2 hours uninterrupted. (if the changing LED comes on, it will remain red until over 10%)

• Try charging from a different source, using a PC or different wall outlet.

• Using a different cable/brick (if available)

Let us know if these steps above were helpful; we look forward to your response!

Hi again, I have tried this for about 2 weeks and have gotten nowhere. I wonder if there is anything else I could do or if I will need to replace it entirely.

Thanks

Hi @MaxKiller2006! We see the troubleshooting provided wasn't able to resolve your charging issue. We'd love to help get you back in the game as soon as possible! In order for us to look into this for you, we may require some sensitive information for your account. You can reach our support team here!