cancel
Showing results for 
Search instead for 
Did you mean: 

Quest Link Issue on quest 2. Can anyone help with this?

xXNoviaXx
Level 3
I recently bought the hp omen 2020 gaming laptop so that I would have a vr ready pc to play games on my oculus quest 2. I have Nvidia Geforce GTX 1160 Ti so it meets the requirements for the quest. Whenever I link my quest to my pc and click a game such as vrchat, my quest shows me in a white room with a screen in front of me with the vrchat logo and says either waiting or loading but the game is on my pc monitor tracking and showing what should be coming from my headset. The screen never does load into my headset. After trying to play through steamvr it just tells me that my headset is not connected to the same video card as my monitor. I'm also using the official quest link cable. Is there anyway I can fix this? I feel like i've tried everything with no solution. 😞
22 REPLIES 22

mungofatkid
Level 2
Do you have a fix?  I too have this problem.  Support has no fix.  Internet has no fix.  I've done everything and my product doesn't do what they said it would.  1 month with a busted unit and they haven't even offered me a $5 off coupon to try to keep my as a customer.  Ive spent waay to much money trying to get this brick to work.  Support only offers sorry, have patience, and what chipset issue?  Click on this link for more info....  which turns out to be the minimum specs sheet that I exceed.  My only problem is that they don't support the notebook version of my graphics card just the desktop version.  Yaaaaaay!!!   Soooo pissed.  They wont even tell you how to get your money back even after you ask them five times.  Guess I'm stuck with a unit that only does half of what was advertised.  Never buying one of these again.   

roy_carter_165
Level 2

xXNoviaXx said:



PITTCANNA said:

Type c isn't always 3.1.  that said sometimes laptops have a setting in there bios or uefi, and it will allow a hard disable.  But what is your laptop cpu and ram ?


These are my specs:
CPU: AMD Ryzen 7 4800H with Radeon Graphics            2.90 GHz
RAM: 16 GB
GPU: NVIDIA Geforce GTX 1660 Ti


I have the exact same gaming laptop with the exact same issues.

MiaKatRio
Level 2

Hey guys, hate to revive a dead thread but I have this exact issue as well, same setup and everything. Did anyone ever find a solution for this? I've exhausted all my options looking for a fix, hopefully someone has discovered one.