cancel
Showing results for 
Search instead for 
Did you mean: 

Release Notes for Rift - Oculus App 1.6

cybereality
Level 15

Here's what's changed in the Rift ecosystem recently.

Release 1.6

We've improved the Oculus Store and your Oculus Library in the following ways:

  • Coming Soon: Check out future apps and games, and get notified when titles you like are ready.
  • Improved Downloads: You can now choose how much bandwidth to use for Oculus downloads. Also, downloads now resume seamlessly if interrupted.
  • Automatic Updates: Games and apps installed on your computer from the Oculus Store can now be automatically updated whenever a new version is released.
  • User Ratings: Rate games and apps, and also see how highly other users have rated an app. User ratings are only available in VR, from Oculus Home.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
72 REPLIES 72

LZoltowski
Volunteer Moderator
Volunteer Moderator
I haven't seen any changes, but the my Rift hasn't had any issues with performance or operation.
Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another 🙂

vrmower
Level 7
Win7 x64 - Let software update from 1.4 (If not broke, mess with it).  When done updating software and firmware everything worked except no sound.  No error messages of any kind displayed during any updates.

Checked device manager - Rift Audio device showed as failed with code 28.

Uninstalled all Rift devices from device manager, ran oculus-driver yet this didn't fix the problem.  All was reinstalled except audio still failed with code 28.

When you run oculus-driver it leaves a bunch of driver files in %temp%\oculus.

In device manager manually right click over failed rift audio / update driver / browse computer for driver software / let me pick from list of device drivers on my computer / pick sound, video and game controllers from hardware types / click have disk / point to %temp%\oculus\win* folder corresponding to your version of windows.  Rift audio now working.

This problem is reproducible for me.  Simply running oculus-driver again breaks rift audio with code 28 error.

Disabled network access to Rift again to avoid future headaches.  There really needs to be an Oculus provided setting to stop the mandatory updates because as typical for systems of this kind update process isn't robust  enough to assure new problems will not occur as a result.

Qba73
Level 3

apparently support was added for up to 4 Rift sensors, roomscale anyone?

http://uploadvr.com/oculus-rift-now-supports-multiple-cameras/


I9 13900k @ 5.8ghz AC (water), Asus Z690 Apex, 64gb gskill 5600 DDR5, Aorus 4090 Waterforce @ 3ghz

RedRizla
Level 15

Dominique said:

How do I actually give a rating? In home I see the ratings a game has, but I have no idea how to put them myself.


Where do you view the rating of a game? I don't see any rating in Oculus Home for games?

PunkSkeleton
Level 2
When I got my rift 2 days ago all the updates installed without any problems. Now I was getting messages stating that rift is not connected. Then after Oculus reboot it finally works. Lost over half an hour and also graphics settings in application.

Zenbane
Level 15
Always make sure to perform a full PC reboot after the update. Windows Services play nicer when they start from scratch.

Anonymous
Not applicable
I have an issue with the my oculus store... I have the following message:
"Sorry we couldn't update Oculus", each time I try to update to 1.6. I also noticed this problem happens on certain games, not everyone. I don't understand. My oculus store is installed on a HDD (which is not C) on which I'm an administrator with the full rights (Win7). Why would some apps install and some wouldn't?
I already rebooted my computer but it doesn't work either. I can't file any similar case anywhere.
Any idea please?

edit: SOLVED with a "repair" in oculus setup.

Bloodlet
Level 8
It's true! The repair function is actually working now.

I've tried to use it twice in the past and it's failed both times leaving no option but to completely re install OH and my library.

I had to do a system restore this weekend due to an update screwing up some needed settings (not Oculus).
and restored pre Oculus update which screwed up OH and it wouldn't launch. (This is the second time I've had this scenario!).
This time however the repair function worked perfectly. It updated OH back to 1.6 and my library remained intact.

Bravo Oculus team 😉

Marquis
Level 2
When it will be possibe to install OCULUS anywhere instead of SYSTEM DISK ?

LZoltowski
Volunteer Moderator
Volunteer Moderator
@Marquis You can install anywhere as long as it is a Physical Drive and a Simple Disk Partition (Dynamic is not sported). Mine is running on drive K: and not C:
Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another 🙂