cancel
Showing results for 
Search instead for 
Did you mean: 

Why does Rift REQUIRE DISABLING USB 3.0?!?

TheInternal
Level 3
I've run into this issue in a few different usage cases, and I'm quite annoyed, since no parties involved have claimed accountability or provided an explanation.

I've encountered this issue on Gigabyte and Asus motherboards, with the present one I'm trying to address being on my Gigabyte Pheonix SLI x99 board paired with the i7-6850k, 16 x 2 GB DDR RAM, and a Geforce 1080 GPU on the April 2018 Windows 10 Pro update. I'm running room scale with 3 sensors. It doesn't matter if the three sensors are in USB 3.0 ports or if only two are in 3.0 ports and one is connected to a USB 2.0 extension. 

I am FORCED to disable ALL USB 3.0 via disabling the xHCI in my motherboard BIOS if I want my Oculus to not error out / disconnect every 5 to 10 minutes. 

Why am I forced to disable USB 3.0 to run my Rift? What's causing the disconnects (my guess is a conflict between Oculus software and something in Window's hardware management). 

Has anyone else in this forum personally encountered this yet?

15 REPLIES 15

TheInternal
Level 3
I've read of numerous users having similar issues, but none of the companies involved are willing to admit any error (I swear, global corporations are worse than spoiled 5 year olds when it comes to that stuff) or provide a solution.

Digikid1
Level 12
That’s a issue with your motherboard then. The rest of us run usb 3.x just fine with Oculus. If it’s a real concern for you then I’ll suggest grabbing the Startech Quad Bus USB3 card from Amazon. 

TheInternal
Level 3
I bought a USB card for one of the builds. Didn't address the issue. What's your setup, digi? Saying "no, it's just you" without any point of reference isn't very helpful.

Digikid1
Level 12
I didn’t say that at all. I said it’s an issue with your motherboard. 

TheInternal
Level 3
It's the same issue with three different motherboards across two manufacturers? That seems highly unlikely.

nalex66
Volunteer Moderator
Volunteer Moderator
I’m using a Gigabyte X99 mobo, and I haven’t had that problem. I did add the StarTech quad USB card when I got my third sensor (so I could run all three sensors at USB 3.0 without worrying about using up all my USB bandwidth for other devices), but even when it was all running through my mobo I didn’t have any disconnect issues. 

Did you go through the Device Manager and turn off power management for all you USB controllers and devices? It could be Windows turning off the sensors to save power. 

i7 5820K @ 4.25GHz | RTX 3080 Ti FTW3 | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
SSDs: Intel 660p M.2 2TB, 3x Samsung Evo 1TB | Startech PCIe 4x USB 3.0 | Startech PCIe 2x USB C 3.1 gen2

Thmoas
Level 8


It's the same issue with three different motherboards across two manufacturers? That seems highly unlikely.


And there are thousands of people where it works fine. It works for me, 4 sensors on USB3.0 ...

Maybe you have one or more faulty sensors? Also, do you spread the sensors? Each USB controller can only handly 1 or maximum 2 USB3 sensors. So if you put 2 on the native mobo (Intel) chip you need another approved controller on that mobo for the other sensors.

In order to achieve 4 sensors on USB3 I installed a PCI-Ex USB3 expansion card.

Anonymous
Not applicable
The Rift does not require disabling usb 3 ports. The Rift works best on USB 3 ports.
It can be finnicky on which USB 3 ports, and as others have mentioned it is important to disable the power savings Windows by default assigns to the sensors and HMD.

I personally run 2 sensors and the HMD on an Innatek USB 3.0 PCIe powered card. Back when I ordered my Rift I ran the compatibility tool and it had flagged my onboard USB 3.0 as being problematic with the Rift.
I set it up with the Innatek card when I got it, and has been smooth sailing ever since (Jan 2017).

Some troubleshooting may give a clue.

SkScotchegg
Level 11
Yeah it's strange how people have issues with sensors and usb 3.0.

BTW have you tried plugging them into 2.0 as I heard people on these forums say they did that and no issues?

I think I have all mine plugged into 3.0 on my ASUS motherboard and no issues here.
UK: England - Leeds - - RTX 2080 - Rift CV1 & Rift S - Make love, not war - See you in the Oasis!