Showing results for 
Search instead for 
Did you mean: 

Windows 11 user vote, How many people are having issues with Windows 11 and any occulus product

Level 4

Could you all please comment on here if you are having an issue with any Oculus product and windows 11 so i can gauge the impact of Oculus not updating the drivers?


As it was too late for me to stop the migration to Win11 I just gave it a try. And, I must say that so far I have no issues using Win11+Oculus, too. So I guess I'm also one of the lucky ones after all. 🙂

Edit: I'm taking that back. AirLink isn't working anymore under Windows 11. WTF?

Level 2

Yep my rift S isn't working and support told me that Windows 11 isn't supported and to go back to windows 10. This seems utterly ridiculous as windows 11 has been out long enough for them to have made it compatible by now. Its also more aggravating that you can't run a compatibility mode for anything later than windows 8 so that is no help there. Its seems stupid that I have to roll back to 10 just because Occulus/Meta can't write a new driver for their product. 

DONT LOSE ALL YOUR SH*T GOING BACK TO WINDOWS 10!!!! Unless you’re okay with that or have a backup, but 11 has a semi fix for some right now! I’ll come back with an edit that has the link to the fix, but if that doesn’t work I’d like you to know that this unplayable stutter/ghosting/performance degradation issue is present ON ALL BUILDS OF WINDOWS 10/11 VERIFIED BY MORE THAN ONE OF US ON BUILDS 20h1,20h2,21h1,21h2 AND 22h2! Rolling back WONT FIX YOUR PROBLEM. I have a desktop on windows 10 22h2 with the issue, and my laptop was on windows 11 22h2. The previously mentioned fix that I will amend as an edit in a couple minutes didn’t work for me, so I rolled back allllll the way to windows 10 20h1 on my laptop. Issue persists there too 🙂 I’ve tried all nvidia drivers from the dawn of the 30 series up until yesterdays drivers, no dice. I’ve tried ALL versions and builds of windows that have PREVIOUSLY WORKED FINE and they all have this massive issue. The issue stems from some runtime errors (thanks coding devs for really testing your mess before unleashing it on the consumers) and they have absolutely no plans to own up to it. We’ve been pressuring for a fix, a roll back, ANYTHING to make it playable and they just rock you with basic troubleshooting and time wasting support antics. “You’re in good hands! Except for when our code is f*cked, then you can get wrekt!” Please don’t waste your time or your precious data just to rollback to windows 10 based on some bullsh*t support staff troubleshooting step. They don’t care about your time or personal data, don’t walk into disappointment and regret. 

There are lots of users who have their Rift S working with Windows 11 so hopefully someone can chime in here and help you out. It looks like @NumbrOneDad offered some help, so it might be worth exploring their suggestion. As for general tips, make sure you've checked and updated any drivers that you may have (GPU and USB are good ones to start with). 

I definitely wasn't planning on a rollback. It's the cable based on all my research and they are trying to jump me though hoops until they tell me it's the cable and I am boned.

Level 4

It turns out my issue was Windows 11 not being able to update drivers on my system. I did a reset which was required for another issue and found I no longer have any issues with Oculus headsets (Rift and Q2). In the end, the reset also solved the problem around not being able to re-install the Oculus app. The only latency problems I now have are due to dodgy internet connection.

I initially thought cable issues, but these were intermittent and both Oculus approved cables (Ankers), and the Oculus cable itself worked fine on my desktop.

I originally had the problem that the Oculus app would not see my computer as a VR ready device, although their support agreed that is more than met all the VR requirements. This seems now to have been fixed.

I do still have issues with my Developer account and the Dev Hub not recording a verified account, even though logging into my dev account on a browser states Dev account verified.

I did have limited success with some of the recommendations made in this forum, but again they appeared intermittent and cause other issues anyway, so were not ideal solutions.
I expect there are still USB issues, as I have had to re-install USB drivers for other devices when they don't connect or remain connected.

I would add that with Nvidia drivers I get better performance with the Studio versions than the Games versions.

Level 2

1 vote by me. Hungary. Cable link dead since latest win 11 + oculus app update. USB 3 works, / USB test 2.9GB/s but blank screen in VR headset when starting cable link. I was fine , going to dead aprrox 2-3 weeks ago.

@MetaQuestSupport wrote:

Hey there, Windows 11 isn't directly supported by Oculus devices quite just yet. Windows 11 support is on the way soon, but we have no other information to share just yet. We recommend using Windows 10 until 11 is fully supported. Keep your eyes peeled to our blogs and socials and we'll be sure to let everyone know as soon as Windows 11 is supported.

Really ? Win10 isn't even supported by Windows. Come on. Win11 has been out years now 

@ROOMADMIN Windows 11 actually began being supported a couple of months ago. If you're still having some issues and fit under our Link or Rift/s requirements, I'd suggest making a ticket with our support team since they can get a better look into the issues.