Showing results for 
Search instead for 
Did you mean: 

Meta Quest Developer Hub Stuck at Authentication step "Continue in your Browser"

Honored Guest

Meta Quest Developer Hub says to "Log in with a Meta account"

I click the button, it opens a window in my browser with a login form saying "Continue as *my name*"

I click that button and it does nothing. MQDH just says "Continue in your Browser"

I've tried the following:

  • Different browser
  • Incognito mode
  • Waiting a few seconds before logging in
  • Restarting PC
  • Installing older versions


Nothing is working. I just want to log in. I'll gladly type in my username and password.

I know for sure I'm not the only one with this issue.  Has anybody figured out a solution?



Just want to say I'm having the same problem. Have tried all the same things as you have listed. This is very annoying indeed! Please let me know if you find a  solution.

Honored Guest

I had the same issue and it was resolved recently. Check it out.

No luck here, I'm afraid. I updated MQDH to 4.4.0 but the same is happening. Luckily it works on my laptop or I'd be stuck.