Showing results for 
Search instead for 
Did you mean: 

Oculus Platform Command Line Utility for Linux

At the moment "Oculus Platform Command Line Utility" is only provided for Mac and Windows.

Any chance of providing a linux build?

I am trying to setup CI instance in AWS, and this ( being able to upload builds ) is one of the last things to get working.


+1 - We have the rest of our CI ready for switch to docker containers but a linux version of the command line utility is needed to make our pipeline clean. It would dirty and complicate things to have to introduce a Windows or macOS HVM and we wouldn't be able to use a fully managed pipeline like Bitbucket or GitLab.

Hey, Solaris.  Ian from Skyryse here.  Long time no see.  I ran into this same issue and was able to work around it by using Wine to run the Windows version of the tool.  I couldn't get it to work on Alpine Linux because of musl so I went with Debian slim instead.  Installing Wine makes the Docker image much larger than I'd like for such a simple use case but at least it allows it to run on a Linux host.

Do you by any chance have a public docker image to share with the oculus tool installed via wine?

I tried going down that route but ultimately it seemed like too much work to get this all working, vs doing it manually for the last deploy step

Honored Guest

+1 on having a Linux client, it really is a pain when the software stack for all other online stores supports it and i have to make an exception for this one, why would i want to spin up a windows machine just to upload a signed binary to a CDN? You have a MacOSX version, so I'm hopeful it's not too many steps removed from being UNIX portable.

That wine setup does sound like an interesting workaround.