Showing results for 
Search instead for 
Did you mean: 

Stuck at uploading build- Oculus Developer Hub


When I try to upload a build through Oculus Developer Hub it just stays uploading infinitely. The upload loading bar starts and animates, but it doesn't go past that.


Has anybody had a similar issue, and have any advice?






Yes! Still have the issue and I can’t figure out how to fix it! Any word on this yet? 

Worked once and not I can't upload a build to any channel at all.
Tried restarting ODB, my computer, tried different builds. Nothing.

Nothing! I raised a support ticket around the same time I posted, and haven't got a response from that either.

For the time being, I've resigned to making builds and passing them onto a teammate to upload.


I've reinstalled ODB multiple times and still all the same. I'm hoping the next update helps


Just ran into this issue too. I've been sitting waiting for 20 minutes for the build to upload and I don't think it's been doing anything. They disabled web uploads, how am I supposed to upload the build? I just don't understand why they would remove web uploads.

The most recent update changed nothing. Still stuck at an infinite upload 😞

Literally the only way it started to work for me was after I reached out to support and they responded then it started to work..Almost seems as if they have to enable something first for it to work…it’s strange.  Now it works great all the time 

Honored Guest

I also have the same issue. I need to upload a newer build but it stays like it's still uploading. 2 months have passed since this thread was shared but still doesn't work. Does anyone have any solution?

Honored Guest

Yeah, I am having this same issue as well.
I have tried uploading the APK to multiple channels and it is still the constant loading bar.
Really need to find a solution to this that isn't getting every tester to upload via Sidequest.