11-22-2024 10:30 AM
In Unity, I normally cache any GetComponent() if I plan on using it within the Update(). Is the OVRInput.Get similar? Everyone online seems to just put code like OVRInput.Get(OVRInput.RawButton.X) directly in Update() and even inside their IF statements. Is this the recommended method for performance? Is the OVRManager handling everything and I just need to call the OVRInput.Get and not worry about it. What about if I am using that OVRInput.Get in multiple if statements in my script? Should I assign the OVRInput.Get as a boolean at the beginning of the Update() and then use that in my script or would that only really help readability but not have an impact on performance?
Thanks!
Solved! Go to Solution.
11-22-2024 09:31 PM
At least what I have seen is unlike GetComponent(), OVRInput.Get is already optimized internally. The OVRManager handles input polling and state management efficiently, so you don't need to cache these calls like you would with GetComponent(). When you call OVRInput.Get(OVRInput.RawButton.X), you're essentially just checking a value that's already been updated by OVRManager in its internal update cycle. It's more like checking a property than performing an expensive component lookup. If you're using the same input check multiple times within the same Update() cycle, it would be marginally more efficient to cache it.
11-22-2024 09:31 PM
At least what I have seen is unlike GetComponent(), OVRInput.Get is already optimized internally. The OVRManager handles input polling and state management efficiently, so you don't need to cache these calls like you would with GetComponent(). When you call OVRInput.Get(OVRInput.RawButton.X), you're essentially just checking a value that's already been updated by OVRManager in its internal update cycle. It's more like checking a property than performing an expensive component lookup. If you're using the same input check multiple times within the same Update() cycle, it would be marginally more efficient to cache it.
11-22-2024 10:27 PM
Thank You! I appreciate the response.