Showing results for 
Search instead for 
Did you mean: 

Black/Blank Screen on Quest with Unity 2021.24.f1 and the new Oculus OpenXR Integration

Expert Protege


As the title says, I am getting a completely black/blank screen when I build to my Quest after I updated the Oculus Integration to 33.0 and Unity to 2021.21.f1.  I have selected OpenXR under XR Plug-in Management, made sure the Oculus Quest Support was checked off in the OpenXR options and also made ran from the drop down menu Oculus -> Tools -> OpenXR -> and choose Switch to OVRPlugin with OpenXR Backend.  


I am getting no errors, just blackness.  Not even the Unity Logo is appearing. Have others gotten these versions to work together? Has anyone else moved to OpenXR for their Quest?






Expert Protege

I will add that both the Profiller and the Runtime Debugger connect, but show no real time data whatsoever.  Just blank like the Quest itself. Why are others not getting this?  My project is nothing special but I am running Vulkan which did run fine before.Debuggers.PNG

Honored Guest

I'm having the same issue.  Builds to the Quest 2 stopped working on Wednesday 10/13/21 with no update or action I initiated.


I've tried:

  • Updating and removing/installing all XR related Unity plugins
  • re-cloning my project fresh
  • Re-installing Unity and Android build tools
  • Taking some steps found on forums involving inserting an android manifest file with specific uses-features turned on into the Assets/Plugins/Android folder of my project

Literally nothing works.  No unity splash logo, no build failures or anything.  Just a black screen with the "loading ellipsis" when I run the app on the Quest.


If anyone finds anything I am all ears.  Need to get my project up and running on Quest again.

I have the same problem. Just black screen with three circles. This only applies to OpenXR. When I switch Oculus in XR Plug-in Management my build on Quest 2 works well.

Did you find the solution?

I found at least some solution. Change order of Vulkan & OpenGLES. So, now Oculus build works


By changing the order you are no longer rendering with Vulkan so only a fix if you are ok with OpenGL.  

I think it doesn't matter because Unity does all this equally well


Passthrough In Oculus Integration 33.0 is not compatible with your headsets latest firmware, which is, I suppose, v35.    Solution: if your headset version is v35, make sure to use the latest oculus integration package as well, v35 is recommended, even though v34 might still work.