Showing results for 
Search instead for 
Did you mean: 

Build and Run Fail/Hub Fail

Level 2


     I have a weird problem. All of the sudden my project won't build and run, and the Oculus Developer Hub won't open. I have tried uninstalling and re-installing several times, but all it will do is open as a white panel and never load. Strangely enough, I can build and run in another Unity project fine, but every time I build and run in my other project, Unity crashes. I reset a few of the previous settings, Unity gives me one error, which is

D/************************************************************************************ Copyright : Copyright (c) Facebook Technologies, LLC and its affiliates. All rights reserved. Licensed under the Oculus Utilities SDK License Version 1.31 (the "License"); you may not use the Utilities SDK except in compliance with the License, which is provided at the time of installation or download, or which otherwise accompanies this software in either electronic or hard copy form. You may obtain a copy of the License at Unless required by applicable law or agreed to in writing, the Utilities SDK distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License. ************************************************************************************/ #if UNITY_EDITOR using UnityEditor; [InitializeOnLoadAttribute] public class OculusSampleFrameworkUtil { static OculusSampleFrameworkUtil() { #if UNITY_2017_2_OR_NEWER EditorApplication.playModeStateChanged += HandlePlayModeState; #else EditorApplication.playmodeStateChanged += () => { if (EditorApplication.isPlaying) { OVRPlugin.SendEvent("load", OVRPlugin.wrapperVersion.ToString(), "sample_framework"); } }; #endif } #if UNITY_2017_2_OR_NEWER private static void HandlePlayModeState(PlayModeStateChange state) { if (state == PlayModeStateChange.EnteredPlayMode) { OVRPlugin.SendEvent("load", OVRPlugin.wrapperVersion.ToString(), "sample_framework"); } } #endif } #endif

Any help would be greatly appreciated!

Specifically the error in the console:
NullReferenceException: Object reference not set to an instance of an object
OculusSampleFrameworkUtil.HandlePlayModeState (UnityEditor.PlayModeStateChange state) (at Assets/Oculus/SampleFramework/Editor/OculusSampleFrameworkUtil.cs:43)
UnityEditor.EditorApplication.Internal_PlayModeStateChanged (UnityEditor.PlayModeStateChange state) (at /Users/bokken/buildslave/unity/build/Editor/Mono/EditorApplication.cs:441)


Community Manager
Community Manager

Hey dmz.rom! We see you're having trouble with the developer hub and we'd like to help. Please take a look at this thread to see some of the solutions that have worked for others. If you still need help once you tried these solutions, please don't hesitate to reach out to us again.