Showing results for 
Search instead for 
Did you mean: 

Can't LoadSceneModel with Oculus Integration

Honored Guest

Hey guys. 

I'm having an issue of pulling the SceneModel (Room that I have Setup) from any of the scenes in the The World beyond that use the OVRSceneManager to load the SceneModel. I've been using TheWorldBeyond ( to try and get this running. I have also created several new projects on many different versions of Unity (2020.3.18f, 2021.3.18f & 2022) and tried the VirtualFurniture Scenes from the Oculus Integration SDK - receiving the exact same issue as below. 

I've tried default/different combinations of Build Settings, Package versions and Platform types (PC/Mac/Android) and still had no luck. I've attempted some of the solutions in this thread (

I tried this on Windows 11 and Windows 10 and got the same error message. 

Anchor support is set to Enabled as per the project default. 

No matter what I've tried, I always receive the same error message - I'm just unable to pull the Room I've setup:



(PassthroughPet Scene)






(TheWorldBeyond Scene)

I have tried building the scenes using both a PC and a Mac, and each time I load into the scene, it says "The World Beyond requires Scene Data. Please run Room Setup". I've ran the Room Setup around 30-40 times, trying different variations of wall numbers/desks/doors - still no luck of retrieving that data or even running The World Beyond build. HOWEVER, strangely, when I download the The World Beyond straight from the Oculus Store, it runs absolutely fine, it finds the room I've mapped and lets me continue with the experience. This seems to be a Unity only issue? 

I contacted a friend who tested this on his Quest 2, and he was able to simply download the The World Beyond Unity code and click Play and have instant working access to the SceneModel. He was also able to build The World Beyond and go straight into the experience without the message above coming into play. 

As mentioned, I've tried it on a PC and a Mac, still the same issue. I bought a second Quest 2 headset today to test this out, and still received the same issue. 

The only visible difference between my two Quest 2 headsets, and my friends Quest 2 headset, is that my versions are and his version is (an earlier one by a few weeks I think?). 

Can you give me a hand getting this resolved? 



 Message if there is any more detail needed. 

Cheers guys 





Honored Guest

If you were having this issue using Quest Link, it might be you need to enable this setting in the Oculus app:Screenshot 2024-02-08 160644.png