Showing results for 
Search instead for 
Did you mean: 

Cannot get Oculus username: Oculus.Platform.Message "User isn't entitled to use this Application!"

Hello! How are you?

We are currently facing an issue where we can't get a specific username that is set up as part of the company. The error comes from Oculus.Platform.Message and says "User isn't entitled to use this Application!" Is the only user that is receiving this message and we saw that the user is added and accepted the invitation to be part of the company. Is there something else we are missing? We are developing in Unity and using the Oculus SDK

Thanks in advance!


Heroic Explorer

The user isn't passing the entitlement check. Did they sideload the app? Make sure they go to the store page at<appId> and click "Get".

It shows that the user already purchased the app. We also tried adding the user as beta tester but we still have the same issue 😞

Heroic Explorer

You didn't say if they sideloaded the apk or not. Try having them delete the app and re-download by selecting "install" from the app listed in their library on device. 


It's definitely odd to have entitlement issues for a user that is in your developer org.

Sorry, my bad. We did both approaches. Originally we were manually installing the .apk but the last time we tried with the beta channel.

The weird thing also is that this only happens to one user. We have other users who are not even in the alpha track and it is working for them.

Update: We have a theory that is capped to 50 oculus users and above that, even if you add them to the company, it doesn't work. Could it be? Is there a way to check this? (We just added tester 52 and it doesn't work either)

Heroic Explorer

This sounds like a backend issue with the developer dashboard. File a support ticket through the "contact us" link on this page:


They'll need your org name and app id to look into it.

I am not being able to see the contact us link on that page. Do you have a more direct link to that one?

Thank you for your answer 🙂 

Looks like they updated that page!



  1. Click "Get Support" under "Support Center".
  2. Then "Sign In" on the top right.
  3. Then "Contact Us" on the top right.

Awesome! Thank you very much 😄